Jump to content

Search the Community

Showing results for tags 'NANO'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Talk
    • Everything Else
    • Gaming
    • Questions
    • Business and Enterprise IT
    • Security
    • Hacks & Mods
    • Applications & Coding
    • Trading Post
  • Hak5 Gear
    • Hak5 Cloud C²
    • WiFi Pineapple Mark VII
    • USB Rubber Ducky
    • Bash Bunny
    • Key Croc
    • Packet Squirrel
    • Shark Jack
    • Signal Owl
    • LAN Turtle
    • Screen Crab
    • Plunder Bug
  • O.MG (Mischief Gadgets)
    • O.MG Cable
    • O.MG DemonSeed EDU
  • WiFi Pineapple (previous generations)
    • WiFi Pineapple TETRA
    • WiFi Pineapple NANO
    • WiFi Pineapple Mark V
    • WiFi Pineapple Mark IV
    • Pineapple Modules
    • WiFi Pineapples Mark I, II, III
  • Hak5 Shows
  • Community
    • Forums and Wiki
    • #Hak5
  • Projects
    • SDR - Software Defined Radio
    • Community Projects
    • Interceptor
    • USB Hacks
    • USB Multipass
    • Pandora Timeshifting

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Enter a five letter word.

  1. Hi..... 1. On a Pi0w-P4wnP1-ALOA i run a https listener 2. in the Pineapple Nano Meterpreter webmodule i enter LHOST and LPORT of the listener..... 3. now i connect a 3rd device to the nano-hosted "openWiF" and surf to the landing page in a webbrowser.... 4. after a few seconds on the Pi Zero console that happens =[ metasploit v5.0.29-dev ] + -- --=[ 1898 exploits - 1068 auxiliary - 329 post ] + -- --=[ 547 payloads - 44 encoders - 10 nops ] + -- --=[ 2 evasion ] [*] Processing /home/pi/.scripts/listen.rc for ERB directives. resource (/home/pi/.scripts/listen.rc)> use multi/handler resource (/home/pi/.scripts/listen.rc)> set payload windows/meterpreter/reverse_https payload => windows/meterpreter/reverse_https resource (/home/pi/.scripts/listen.rc)> set LHOST xxx.xxx.xxx.xxx LHOST => xxx.xxx.xxx.xxx resource (/home/pi/.scripts/listen.rc)> set LPORT xxxx LPORT => xxxx resource (/home/pi/.scripts/listen.rc)> set ExitOnSession true ExitOnSession => true resource (/home/pi/.scripts/listen.rc)> set AutoVerifySession false AutoVerifySession => false resource (/home/pi/.scripts/listen.rc)> set AutoSystemInfo false AutoSystemInfo => false resource (/home/pi/.scripts/listen.rc)> set AutoLoadStdapi false AutoLoadStdapi => false resource (/home/pi/.scripts/listen.rc)> exploit -j [*] Exploit running as background job 0. [*] Exploit completed, but no session was created. msf5 exploit(multi/handler) > [*] Started HTTPS reverse handler on https://xxx.xxx.xxx.xxx:xxxx And no more not less? 🤷‍♂️ My question is how to get an active meterpreter session to use stuff like "getuid" and "getsystem"!
  2. Hello everybody I'm new to this but I'm pretty familiar with how to have it up and running on Android. Mike recently bought a WiFi pineapple nano tactical kit I upgraded the firmware and did the setup via Android. I got the internet connection going pretty much everything is looking good however I'm having trouble understanding the wifi dongle that the tactical kit came with. I do know that you need it to set wlan2 how can I manage to do that on Android? If I connect the dongle to the nano how do I log in using my phone without going into the pineapple app that requires USB tether? What do I have to use another device rather than using the Android? Any tips would be greatly appreciated thank you in advance.
  3. Hello everybody I'm new to this but I'm pretty familiar with how to have it up and running on Android. I recently bought a WiFi pineapple nano tactical kit I upgraded the firmware and did the setup via Android. I got the internet connection going pretty much everything is looking good however I'm having trouble understanding the wifi dongle that the tactical kit came with. I do know that you need it to set wlan2 how can I manage to do that on Android? If I connect the dongle to the nano how do I log in using my phone without going into the pineapple app that requires USB tether? Do I have to use another device rather than using the Android? Any tips would be greatly appreciated thank you in advance.
  4. Hello people....... tried to get a connection vie Meterpreter to mi Pineapple nano, but all the fuck i h get is this msf5 exploit(multi/handler) > show options Module options (exploit/multi/handler): Name Current Setting Required Description ---- --------------- -------- ----------- Payload options (windows/meterpreter/reverse_tcp): Name Current Setting Required Description ---- --------------- -------- ----------- EXITFUNC process yes Exit technique (Accepted: '', seh, thread, process, none) LHOST 192.168.178.24 yes The listen address (an interface may be specified) LPORT 4747 yes The listen port Exploit target: Id Name -- ---- 0 Wildcard Target msf5 exploit(multi/handler) > run [*] Started reverse TCP handler on 192.168.178.24:4747 [*] Sending stage (179779 bytes) to 192.168.178.25 Who knows more?
  5. I just got the pineapple nano in the mail today. I tried hooking it up to the Note 4 and enabling the USB tethering as shown from the setup video. For some reasons there have been issues enabling the USB tether. I'm not sure if it's because I am using Verizon. Are there any ways to go around this issue.
  6. Hi have the nano and the tetra mk 5.8. I was wondering if I could use them as simple wireless adapters? Is there a way to just plug them into my computers (mac, windows and a linuxmint) and arrange them to work the way my alfa adapter pretty much works when plugged in (to linux machine). I often am carrying around the nano and was wondering if it would boost the wifi signal range of my galaxy s10 as well. thanks
  7. Every time I watch tutorials about the Wifi Pineapple, I see that the hosts are able to get more information about clients by selecting them in the recon menu by MAC address. But when I hover over the clients in either of my Wifi Pineapples (both Nano and Tetra) the 'No' symbol appears (circle with the diagonal line through it) and does not allow me to select the item. Is this a common issue and is there a fix for this I have factory reset both devices twice already and I am still getting this issue. For further clarification this is the information that is in the help menu for the Wifi Pineapple: Clicking the menu button next to an MAC address shows a menu providing buttons to add or remove the MAC from the PineAP Filter or PineAP Tracking feature. Opening this menu will automatically look up the MAC address in the OUI database if it has been downloaded. In order to download the OUI database, either the WiFi Pineapple or the web browser itself must have internet access. Deauth uses the multiplier to send multiple deauthentication frames to the target Client. A multiplier of 2 is twice as many deauthentication frames as a multiplier of 1. The menu button is disabled when a scan is active (ie. not stopped or paused). Clicking the menu button next to an SSID shows a menu providing buttons to add or remove the SSID from the PineAP Pool or PineAP Filter. Deauth Clients will send deauthentication frames to all associated clients currently recognized by Recon using the multiplier. A multiplier of 2 is twice as many deauthentication frames as a multiplier of 1. etc............... Further information that may or may not be relevant: OS: Windows 10 Version 1803 OS Build 17134.706 and Kali Linux v3.30.2 Browser: Google Chrome Version 74.0.3729.108 (Official Build) (64-bit) and Firefox
  8. Hi Guys, I am somewhat new the the Pineapple, more specifically the Nano and I am still in the process of learning how to use Linux. To begin, I have been trying to use the PortalAuth module but when trying to clone using any of the injects and other options it errors out with an error saying that is can't find the tinycss module. Going by some posts on the web it was suggested to try and install the latest version of the module from the git repository to the SD card, as the space is limited on the NANO. And yes I did remove the current version of the module first. After upgrading I am now getting the following error instead; Traceback (most recent call last): File "/pineapple/modules/PortalAuth/includes/scripts/portalclone.py", line 4, in from PortalCloner import PortalCloner File "/sd/modules/PortalAuth/includes/scripts/PortalCloner.py", line 12, in import requests File "/sd/modules/PortalAuth/includes/scripts/libs/requests/__init__.py", line 58, in from . import utils File "/sd/modules/PortalAuth/includes/scripts/libs/requests/utils.py", line 26, in from .compat import parse_http_list as _parse_list_header File "/sd/modules/PortalAuth/includes/scripts/libs/requests/compat.py", line 7, in from .packages import chardet File "/sd/modules/PortalAuth/includes/scripts/libs/requests/packages/__init__.py", line 83, in load_module raise ImportError("No module named '%s'" % (name,)) ImportError: No module named 'requests.packages.chardet' Any help is really appreciated. Thanks!
  9. Anybody have a guesstimate as to when the Pineapple WiFi will be restocked?
  10. Hey all, When installing stuff to the sd card, it often needs symlinking to the working directory on the pineapple nano to complete the installation. For one-off's its fine to do manually, but on larger git install's or opkg packages with many folders/files it can be a PITA. So I got to looking around for tools/scripts, I found a few (some better than others) but think I found something that works, and works well on the pineapple YMMV. It has one small sized dependency so can be installed to pineapple nano rather than sd : - opkg update && opkg install coreutils-realpath You can run it multiple times and it will only create links for unlinked files so could be run on the base directory after adding new files like: - aln -s /sd/usr/ -d /usr/ I have been using it for a few days and so far so good, so figured I would share for others to try out. https://github.com/eyit/aln Hopefully its useful to others.
  11. My WiFi pineapple won't connect to the internet when set up the way it's detailed in the windows 10 setup video. I've already looked at these threads: https://forums.hak5.org/topic/37142-questions-about-wp6sh/ https://forums.hak5.org/topic/37387-nano-refusing-to-connect-to-internet/ and downloaded wp6.sh, but when I try to execute it, it says permission denied. It originally downloaded to /root/, but when it wouldn't work I moved it to /bin/ and it still wouldn't work. In addition, when I try to get modules or bulletins on the pineapple it doesn't work. The only way I can get it to connect is by using client mode, which interferes with PineAP since it only lets me use wlan1. How can I get the USB ethernet function working?
  12. Hey guys, I'm following a tutorial on how to set the nano up for war driving and for some reason when i try to telnet to my phone to connect to the gps (using the share gps app the terminal gives me an error as if telnet isn't a valid command root@Pineapple:~# telnet localhost 50000 -ash: telnet: not found https://holisticsecurity.io/2016/02/27/wardriving-wifi-pineapple-nano-mobile-world-congress-2016-barcelona/ any help would be greatly appreciated 🙂
  13. Has anyone managed to get a WP Nano working in a chroot on a Chromebook? If so ... how?! (I'm using an Asus Flip 4gb)
  14. Hi folks, i am wrestling with wlan2 connection problems. Have spent maybe 8 hours on this and i have a tentative solution that works some of the time, but i don't understand what is happening really. (1) I had a little wiFi dongle (Cheng Hongjian, but i can't find the commercial brand name, it was mentioned in a forum here so i ordered one) plugged into the Nano, as wlan2, to provide "client internet access" and for my management. It did seem to be working, and then i didn't use the Nano for a few weeks. This was in "standalone" mode with no USB cables attached to the computer. (1a) I installed C2 and got it working. The rest of my points below are with C2 *not* in the mix. (2) Then, several days ago, i noticed that wlan2 got an IP addr(192-addr) from my home router, but a few minutes later it would lose the 192-addr and get a 172-addr which i couldn't get to (because i didn't have usb connection to computer). The blue light on the dongle was no longer lit. (Back when this was working, the little wiFi dongle was getting listed in Fing as Cheng Hongjian.) Reboot, cold reboot. After wlan2 lost the 192-addr, it would not get it back after reboots, disconnect & reconnect WiFi Client Mode, or trying to add 192.168.0.1 to the routing table manually. (2a) Power supply was a 28000mAH brick with the Y-cable. (3) I then connected the Nano via the Y-cable to the laptop via Y-cable to a powered usb hub. With the Cheng-Hongjian wiFi dongle in the wlan2 slot. Sometimes i could get a 192-addr for wlan2, but if i did, it would go away after a few minutes, and the blue light on the *dongle* would go out. (4) So i replaced the dongle with my Alfa 036NHA. Similar behavior, either unable to get a 192-addr or it would get it and then drop it and get a 172-addr (5) Late last night (!) tried something radical: i connected to my neighbor's router (for which i *def* have permission, but i don't abuse it or even need to do it much). The wlan2 with the Alfa got a 192-addr right away, tentative hopeful. (6) Disconnected from there, tried to reconnect Wi-Fi Client Mode to my home router,**but** i changed the MAC address of wlan2 to something random. This worked,and i ran Recon for 9 hrs till this morning using the Alfa on wlan2. (7) Cold reboot. The Cheng-Hongjijan dongle in wlan2. Would not get a 192-addr. Alfa in wlan2. Would not get a 192-addr. (8) A combination of (a) reboots, (b) change MAC addr on wlan2, (c) disconnect & reconnect WiFi Client Mode to my router (my router SSID was listed twice for some reason), and (d) try to manually add to the routing table on that screen -- this has resulted in a stable 192-addr for wlan2 now for the past 90 minutes, and it'll probably stay that way until i reboot again and try to track down further what is going on here. (Next shot at this, i'm taking down more notes on what i did each try.) (9) Tentatively i'm thinking that the Cheng-Hongjian dongle went bad, but the Alfa was behaving similarly. I'm going to keep the Alfa in there for further tests. It works fine with an R-Pi so i'm pretty sure it isn't hosed. Thanks for any comments. --orrin
  15. Hi there, I got up and running with the nano, and during reconning the SSID pool filled up with SSID's. I even got some clients connected, but they get no IP address. Has anyone an idea? I use OSX High Sierra with Internet Sharing enabled. I changed the network range of the bridge adapter that gets created when enabling Internet Sharing (credits to the guys of Amsys), it is now in the default pineapple range (172.16.42.0/8). Regards
  16. https://www.picz.in.th/image/fFGI3Q https://www.picz.in.th/image/fFGMbS Sorry,How to solve? I try configure ip static IP 172.16.42.42 mask 255.255.255.0 gateway 172.16.42. dns 172.16.42.1 it doesn’t work Please help me !!!!!!!!
  17. I installed an SD Card and saved a module to it. When I look under "Installed Modules" I cannot find at it on the GUI but it is on /sd/portals/evilportals. root@Pineapple:~# cd /sd root@Pineapple:/sd# ls etc lost+found modules tmp root@Pineapple:/sd# cd modules root@Pineapple:/sd/modules# ls EvilPortal root@Pineapple:/sd/modules# cd ~ root@Pineapple:~# ls portals root@Pineapple:~# cd portals root@Pineapple:~/portals# ls root@Pineapple:~/portals#
  18. Hi, I get a Pineapple Nano recently. It is setup following the setup video, can download the Bulletin in Dashboard, and can download modules also. The problem is that, my mobile phone (iPhone 7) can find the Nano, but can't connect to it. How to fix it? I check the status of the Nano, it has internet connection (IPv4), but in the "events" of the "configuration" of its "property", it shows that the events "\USB\VID_0B95 & PID_772A\8DDB93" needs be further installed. Is this relevant to the above connection problem? and if so, how to further install them? thanks.
  19. I just got my Wifipineapple nano today, and while flashing the firmware, my power went out. Now I am unable to access the control panel, or any part of the nano (the light turns blue for a second, flashes, and stays blue for about 5 seconds before turning off). Thank you.
  20. I can get the nano up an running, turn on pine ap with all the boxes checked, can get my iphone to hook up as a client and can change splash page etc etc.. but on multiple computers i have tried the nano and it, sometimes after 5 min, sometimes 10 or 15 but never longer than that, will just stop working. If i try to recon scan it just freezes at 100% and if i try navigating to the dashboard all the boxes are blank and basically it all becomes unresponsive until reboot. I have tried factory reset multiple times and uploading the latest firmware again and it still happens. Anyone else having this problem or did i receive a dud? basically is okay if i can get the info i need in a couple min, but if i want to scan continuously or set up any of the modules then its pretty useless
  21. Its been a long time since i started using the nano again. I took a long break from all this and now that i am getting back into it, i dont know what im doing. I have installed all the updates and the boots fine. I just don't know how to use PineAP and actually keep the internet connection so that when clients connect they get a wifi connection still but that's after this next issue you will being reading in a second. I also tried using the client AP in the networking tab and i kept it at 100 clients but nothing can even connect to it in the first place. Also i am on the network that i am trying to take over with PineAP. Back when i used to do this stuff a lot it worked well it deauthed my network and all the clients connected to my wifi pineapple that look identical to the original one just that the real one was now getting deauthed every second. If it helps i also have a 5G network that sometimes clients connect to if the other gets hit off. I am going to leave some screenshots of my wifi pineapple settings.What i am really wanting to know though is if this project has died and it is not as useful as it used to be like it was in 2016-2107 for me. What else can it do besides the PineAP thing that makes clients connect to and deauths all other networks. ANY HELP is greatly APPRECIATED. https://imgur.com/a/7BcF2iL (post of all screenshots)
  22. Is there a list of all modules and their functions of the Pineapple (Tetra if it matters) wich i bought recently. Im new to hak 5 Products and all that hacking stuff but I want to learn and ya gotta start somewhere (so why not with a >200$ device).
  23. Received my Nano yesterday, am busy discovering how to use it. Today, after connecting to it via wifi (with the antennas on it), for some reason i had the antennas off, and then plugged it into my laptop via the USB and was doing some learning... with no antennas for about 10 minutes. I realized after 10 minutes that my phone was picking up the broadcast ID for the management AP, duh! Which means the Nano had been transmitting (what, 10x per second?). So i wonder how much damage that did. I know from amateur radio, can't xmit without an antenna. ... I measured the Nano's signal strength by walking around with my phone and a wiFi signal strength app, and the Nano was putting out maybe 10dBm less than my ISP-router, and i went outside & i still got a signal thru 3 walls 60 ft away. So anyway, thanks for any comments. Harsh comments okay too. --orrin
  24. Hello Guys, I'm new to Pineapple and I need some help please :)) I got the NANO and it works great on my windows machine but when it gets to my macbook pro I can't get it to run (with Internet connection) :( I tried some step by step tutorials but they didn't work :( Plug the NANO in and get the connection and setup the gui no problems but I can't download the modules or the bulletins :( I'm connected to my home wifi and shared the internet connection with the Pineapple-adapter but it won't work :( anyone got some ideas or tips for me :)) THX :)
  25. I've been getting my Nano all set up and am finally happy with how things are configured. It's my first Pineapple and so far I'm happy :) One thing I've been having an issue with is adding an additional wifi card and getting it to work properly. I have both the Alfa ASWUS036H and TP-LINK TL-WN722N... The Alfa doesn't really detect properly as a wifi device but does show up in the lsusb command. I tried installing an opkg driver update for the realtek chipset and it seemed to install but not to help. As for the The TP-LINK... It shows up in both lsusb and as a wireless device within the "Wi-Fi Clients" section on the "Networking" page within Pineapple admin interface. However.. when I try to use wlan2 (the TPLINK) to connect to a local AP, it ends up using wlan1 even though I have instructed it to use wlan2. Any thoughts? I think one time I was able to establish a link from wlan2 -> to local wifi network via the wifi client ... but as soon as I would start PineAP things would go haywire and quit working. Ideally PineAP should work fine since it's only using wlan1... some kind of conflict ? My goal is to add a third wifi adapter so I can use it to connect to a local wifi network and bridge the internet access from that card over to any clients that connect. Thanks in advance!
×
×
  • Create New...