Jump to content

DVM

Members
  • Content Count

    3
  • Joined

  • Last visited

About DVM

  • Rank
    Newbie
  1. I got it to sort-of work by adding this to /etc/dnsmasq.conf dhcp-option-force=224,my_payload_string Very strange but good enough for now. Thanks!
  2. Thanks for the suggestion. I have read that and made another test: dhcp.lan.dhcp_option='224,172.16.60.64' '42,172.16.60.64' Now I see option 42 in the DHCP Ack message but not 224
  3. I'm trying to setup a NAT with a DHCP server on the LAN side that will deliver a custom custom DHCP option to my victim. I have tried adding the dhcp_option list to dnsmasq #!/bin/bash # custom function setup() { # Show SETUP LED LED SETUP # Set the network mode to NAT NETMODE NAT sleep 5 uci add_list dhcp.@dnsmasq[-1].dhcp_option='224,"my_payload_string"' # Restart dnsmasq with the new configuration /etc/init.d/dnsmasq restart } function run() { # Show ATTACK LED LED ATTACK } or replacing dnsmasq with lan ... #uci add_list dhcp.@d
×
×
  • Create New...