Jump to content
Hak5 Forums

jeff03038

Active Members
  • Content Count

    6
  • Joined

  • Last visited

About jeff03038

  • Rank
    Newbie
  1. Upgraded to Ubuntu 18.04, ran the wp6.sh script. The pineapple would work after I disconnected and reconnected and reset Network Manager but it would work sometimes. The Route Table was also messed up, it had dual entries for 172.16.42.0 as an example. Instead I came up with procedures that work really well. Take a look ---------------------------------------------------------------------------- prior to plugging Pineapple in #Ensure /etc/resolv.conf has DNS entries if not add DNS, ignore warnings nano /etc/resolvconf/resolv.conf.d #If nothing there add nameserver 8.8.8.8 nameserver 1.1.1.1 #Ensure ufw is disabled ufw disable #Make sure routing is enabled cat /proc/sys/net/ipv4/ip_forward #Set to 1 if 0 nano /proc/sys/net/ipv4/ip_forward #Plug-in Pineapple Route Table will look soemething like this: root@redsox1:~# route Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface default _gateway 0.0.0.0 UG 0 0 0 wlo1 default _gateway 0.0.0.0 UG 20100 0 0 enx00c0ca914973 10.0.0.0 0.0.0.0 255.255.255.0 U 600 0 0 wlo1 link-local 0.0.0.0 255.255.0.0 U 1000 0 0 enx00c0ca914973 172.16.42.0 0.0.0.0 255.255.255.0 U 100 0 0 enx00c0ca914973 #Delete the additonal route added by the Pineapple route del -net 0.0.0.0/0 dev enx00c0ca914973 Table should look like this root@redsox1:~# route Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface default _gateway 0.0.0.0 UG 0 0 0 wlo1 10.0.0.0 0.0.0.0 255.255.255.0 U 600 0 0 wlo1 link-local 0.0.0.0 255.255.0.0 U 1000 0 0 enx00c0ca914973 172.16.42.0 0.0.0.0 255.255.255.0 U 100 0 0 enx00c0ca914973 #http into the pineapple http://172.16.42.1:1471 and change the default route to 172.16.42.201 #Web into 172.16.42.1:1417 and make sure you can update bulletins #Now you have internet sharing with the Pineapple!!!
  2. jeff03038

    Can't install SD card

    I had the same problem. I reset the pineapple (nano) to factory defaults, unplugged it inserted the SD Card Reboot and everything worked. Also disable ufw on Ubuntu 16.04. I am using version 3.2.3 on nano.
  3. jeff03038

    Cannot See Installed Modules after Inserting SD Card

    Reset Nano to Factory Defaults with SD Card inserted... Now everything works fine. Just an FYI for anyone interested. Also, I had to disable UFW in Ubuntu 16.04 to make everything work. Sorry for Posting in Wrong Place 😏
  4. jeff03038

    Cannot See Installed Modules after Inserting SD Card

    Sorry Buddy, the Pinned Topic says Nano and SD Card. Is there somewhere else I should be?
  5. jeff03038

    Cannot See Installed Modules after Inserting SD Card

    btw, I am using nano 2.3.2
  6. I installed an SD Card and saved a module to it. When I look under "Installed Modules" I cannot find at it on the GUI but it is on /sd/portals/evilportals. root@Pineapple:~# cd /sd root@Pineapple:/sd# ls etc lost+found modules tmp root@Pineapple:/sd# cd modules root@Pineapple:/sd/modules# ls EvilPortal root@Pineapple:/sd/modules# cd ~ root@Pineapple:~# ls portals root@Pineapple:~# cd portals root@Pineapple:~/portals# ls root@Pineapple:~/portals#
×