Jump to content

Viceroy

Members
  • Content Count

    3
  • Joined

  • Last visited

  • Days Won

    1

Everything posted by Viceroy

  1. I used the UUID of the sda1 partition instead of the /dev/sda1 for the fstab config.
  2. I was having the same issues until I consoled into my pineapple and just did the formatting and partitioning by hand. This might help
  3. Looks like you don't have any partitions on your sd card. That's why fdisk -l is coming up empty. You could also run the following to see partition info. root@Pineapple:~# block info You can make partitions with the fdisk command from your ssh console root@Pineapple:~# fdisk /dev/sda That should bring you to an interactive fdisk console where you can add some partitions. Probably one for your ext4 and a smaller one for a swap. Then you can use the following to set up your new partitions mkfs.ext4 /dev/sda1 mkswap /dev/sda2 After all that I would run that block command again to see your progress root@Pineapple:~# block info /dev/mtdblock2: UUID="aaa5c26b-1a2d7b95-b821284f-fb82c9e4" VERSION="4.0" MOUNT="/rom" TYPE="squashfs" /dev/mtdblock3: MOUNT="/overlay" TYPE="jffs2" /dev/sda1: UUID="080f6ca2-3e2d-4427-88c4-775b1a51da16" VERSION="1.0" MOUNT="/sd" TYPE="ext4" /dev/sda2: VERSION="1" TYPE="swap" Then maybe another to see what the config should sort of look like. root@Pineapple:~# block detect config 'global' option anon_swap '0' option anon_mount '0' option auto_swap '1' option auto_mount '1' option delay_root '5' option check_fs '0' config 'mount' option target '/sd' option uuid '080f6ca2-3e2d-4427-88c4-775b1a51da16' option enabled '0' config 'swap' option device '/dev/sda2' option enabled '0' That should at least point you in the right direction. Hopefully this helps someone. This is by no means all inclusive... and I definitely didn't spend all day working on it. ; ) Check out https://openwrt.org/docs/guide-user/storage/fstab for more info.
×
×
  • Create New...