Jump to content

Stahlvormund

Active Members
  • Content Count

    16
  • Joined

  • Last visited

About Stahlvormund

  • Rank
    Hak5 Fan

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Hey guys, I am having lots of troubles getting PortalAuth working. When I try to copy a specific website, or often regardless the website, it produces an error. Sometimes the cloning was then still successful, most times not. I did not make any changes to settings after the initial recommended setup and used the modified Harvester injection set, all as described here: https://blog.inspired-sec.com/archive/2017/01/10/cloning-captive-portals.html Also how can I access the WiFi Pineapples root and SD storage manually? I would like to put default portals from github there direct
  2. I am having lots of troubles getting PortalAuth working. When I try to copy a specific website, or often regardless the website, it produces an error. Sometimes the cloning was then still successful, most times not. I did not make any changes to settings after the initial recommended setup and used the modified Harvester injection set. Also how can I access the WiFi Pineapples root and SD storage manually? I would like to put default portals from github there directly for testing purposes.
  3. And interestingly, even tho the error occurs, the website is actually cloned.
  4. Actually copying a website with Portal Auth causes the Wifi PineApple to restart for whatever reason.
  5. So I've been following the steps of this article: https://blog.inspired-sec.com/archive/2017/01/10/cloning-captive-portals.html but when I am waiting for the module to clone the website, it says an error has occured and I should see the logs, even though no log has been produced. This error happens regardless of whether I saved Portal Auth on the SD or Internal Storage of the PineApple Nano. I am trying to clone "https://www.gmx.net" and inject the default "Harvester" injection. This is the error message:
  6. I am reading now here: https://blog.packet-foo.com/2016/07/how-to-use-wireshark-to-steal-passwords/comment-page-1/ that basically without consent of the client I'm not gonna be able to capture secured traffic. The point of why Im doing this is to use this attack in a presentation to shock ppl their credentials could be secretly stolen. So I guess the next approach would be using an EvilPortal?
  7. I can listen to http traffic now using DWall or WireShark. Now it would be exciting to be able to listen to https, to get around hsts or to sniff passwords. or is that currently not possible due to recent security improvements?
  8. I try to update the route but it always stays on br-lan.
  9. I specified the problem a bit more: DHCP is deactivated for the PineApple. I set the IPv4 adress as per instructions but how do I set the IPv6 adress if not automatically?
  10. Also yes, I can access Internet without issues inside my Kali using Firefox.
  11. Alright, so I changed my approach entirely now. I am now using the Oracle Virtual Box 5.2.8 and Linux Kali 2018.1 as the environment for my PineApple. The PineApple is connected via the USB-Y cable to my PC running Windows 7 which then runs Linux Kali via Virtual Box. I can see the PineApple as eth1 in ifconfig in Kali, can access the PineApple in Kali via Firefox and I successfully ran the wp6.sh script. I can load Bulletins and search for updates with my PineApple in Kali. So then I started to broadcast the PineAP's by activating the daemon, ticking all boxes for now as I dont
  12. So the concrete example: With my WiFi Pineapple I caught a WiFi "FreeWifi" from an LTE router my laptop connected with already. So I broadcast that FreeWifi, my Laptop logs into the FreeWifi my Pineapple is broadcasting and my laptop shows no connectivity issues. However, it cant browse webpages, it doesnt get into the internet over the Pineapple broadcasted and hijacked WiFi. The Pineapple itself has internet and can receive updates and bulletins. It also registers the laptop as connected client. Laptop shows no IPv6-connectivity. When I open the IPv6 configuration it receive
  13. I cant even get my devices to receive Internet over the wifipineappletest, nor to properly connect to the fake it sends out! If you need credentials to believe I am sincere, I can provide in PM.
×
×
  • Create New...