Jump to content

nutt318

Active Members
  • Posts

    12
  • Joined

  • Last visited

Posts posted by nutt318

  1. Was wondering if anyone has had any issues with this payload and if you had any feedback. I'm still trying to figure a way to detect if the powershell script fails if its unable to connect to the FTP site. 

    Let me know your thoughts.

  2. I liked the USB Exfiltrator so much I wanted to try and make one that was able to grab everything and dump it to a FTP site. This way if there are large/many documents it wouldn't fill up the BashBunny. Script is pretty simple, it executes a PowerShell script that clears the run history and then starts uploading the users documents directory. It will keep PowerShell running in the background so if there are a lot of files or large files go ahead on unplug the BB once the status light is green, it will just keep going.

    Still new to this and know there will be some bug or errors so welcome any feedback.

    https://github.com/nutt318/bashbunny-payloads/tree/master/payloads/library/ftp_exfiltrator

    • Upvote 2
  3. I've tried switching the payload to Switch 1 and still no luck. I've also changed the ip to 172.16.64.64 and while its plugged in on Switch 1 I can ping the Bunny on the 172.16.64.64 ip. However I cannot SSH into it. It does have git installed but for some reason I still cannot get internet access to it. The Payload just turns solid red after a bit.

    Anyone have any other ideas?

  4. I'm trying to get the Git-Bunny-Git payload to work on switch 2. My device shows up as Ethernet 2 (running windows) and I follow the instructions on the FAQ (http://wiki.bashbunny.com/#!./index.md#Sharing_an_Internet_Connection_with_the_Bash_Bunny_from_Windows) but still cannot get the payload to work.

    I'm just getting a red error light meaning to internet connection. Instructions say to set the IP to 172.16.64.10, i've done that along with IP'ing with a similar IP on my LAN connection. Looking at the logs in /var/log/git.log just say no internet connection.

    Do I need to use the BB.sh script or is that only for a nix machine? Any help is appreciated.

    Thanks! 

  5. 14 hours ago, zerocooler said:

    I have yet to see any log file. Though, I suppose you could have it write one along-side what it's doing.

    It appears to be working but then it never copies any files. I might play around with some different file formats or folder locations.

  6. 1 minute ago, GermanNoob said:

    the pentest folder is not in "/root/" it is in "/"

    when you are ssh'd in the BashBunny, just type 

    cd /

    in that directory you should the the pentest folder.

    If not: Was your install.sh within the switch folder renamed after installation to "...INSTALLED"?

    Gah, Thanks @GermanNoob ! There they are. Not sure how I missed that one. Thanks again!

  7. So I've cut/pasted the tools_installer to the payload switch1 folder and the unplugged, switched to switch1 and then plugged back in. Light looked like it installed correctly and I saw a file created called 'installed-tools.txt' in the root directory.

    Anyways I thought it was installed but doing some more reading there should be a /pentest/ folder however I'm not seeing this. I've even connected over serial and am not seeing this folder.

    Any ideas?

    Thanks!

  8. Is there a log file or anything to see results on what occurred? Just tested this payload and while it created the folder of my machine it never copied any documents into that folder. Yes, there are .pdf files in the documents folder. Just trying to figure out why nothing copied over the the loot directory when the folder got created with my machines hostname.

    Thanks!

×
×
  • Create New...