Jump to content

nrohsakul

Active Members
  • Content Count

    16
  • Joined

  • Last visited

  • Days Won

    1

About nrohsakul

  • Rank
    Hak5 Fan

Profile Information

  • Gender
    Male
  • Location
    Germany

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Just wondering if there is any fix by now to easily install packages over opkg to the sd card. If I try to install packages from opkg using "-d sd", I cant use them afterwards because of the PATH not correctly set. Is there a way to permanently add the correct paths for installed stuff on the sd card ? Or any other easy fix ?
  2. I've got myself a nice little Portal together now. Just have one problem left: After my iPhone connects to the evil portal, it correctly shows the apple captive portal. But after successful authorization the page just reloads and does not close automatically. This looks quite suspicious, even though I can close the window and am connected to the evil portal afterwards. Is there any way to fix this behaviour ?
  3. I´m encountering some issues regarding the authorization. Whenever a client should actually be authorized and should see the message "You have been authorized successfully." the client sees the message "You have not been authorized". But after I reload the page on the client end there suddenly is the success message. In the webinterface on the nano it also then shows the client ip under the authorized clients tab. I´m not quite sure if this is a bug or a mistake on my end.
  4. I am getting some errors when cloning websites - wondering if someone could help me figure out what is wrong. Here is the error log: Traceback (most recent call last): File "/pineapple/modules/PortalAuth/includes/scripts/portalclone.py", line 24, in cloner.cloneResources() File "/pineapple/modules/PortalAuth/includes/scripts/PortalCloner.py", line 182, in cloneResources self.css_urls[_key] = self.parseCSS(urlparse.urljoin(self.url, img.get(tag))) File "/pineapple/modules/PortalAuth/includes/scripts/PortalCloner.py", line 63, in parseCSS r = requests.get(url) File "/pineapple/modules/Portal
  5. Well why does it work than ? I'm confused, 'killall' works fine everytime the module runs or when I execute it through ssh.
  6. Finally got it up and running! I changed the exec method from: exec("killall -9 airodump-ng && cp -f /pineapple/api/wardrive-* /pineapple/modules/Wardriver/log/"); to two seperate ones: exec("killall -9 airodump-ng"); exec("cp -f /pineapple/api/wardrive-* /pineapple/modules/Wardriver/log/"); Thanks a lot for your help newbi3 !
  7. Just tried it out. But still nothing. Not even the logs get moved.. Thanks for your help though. Argh I guess it's something really easy so nobody gets it.
  8. Got that already. Sorry that I'd only showed the function to you. That would be my whole module.php: <?php namespace pineapple; class Wardriver extends Module { public function route() { switch ($this->request->action) { case 'scanForNetworks': $this->scanForNetworks(); break; case 'abortScan': $this->abortScan(); break; } } private function scanForNetworks() { $this->execBackground("airodump-ng --write wardrive --output-format kismet wlan1mon
  9. Thank you very much newbi3 ! Found the mistake in under a minute with your advice. Now I'm facing the next problem.. I got this Button: <button type="button" class="btn btn-sm" ng-show="scanning" ngclick="abortScan()">Stop Scan</button> $scope.abortScan = (function() { $api.request({ module: 'Wardriver', action: 'abortScan' }); $scope.scanning = false; }); private function abortScan() { exec("killall -9 airodump-ng && mv /pineapple/api/wardrive-01.kismet.csv /pineapple/modules/Wardriver/log/");
  10. Hey guys, Just started writing my first module for the NANO. I'm quite new to php, html and js. Maybe thats why I encountered some little problems here and there. The biggest one in the moment is: If I get the module on my NANO and try to open it - nothing happens. I assume I've got a syntax error or something, but just cant find it. Is there a way to get some output, so I see the error messages that would pop up ? Or maybe someone of you could help me with my code. Its here on github: https://github.com/nrohsak/TestModule Thanks in advance greetings nrohsakul
  11. Is something wrong with the handshake capture ? Every cap file that, according to the module, should have a handshake in it seems not to have one in it. I uploaded them to onlinehashcrack and get this message: "we are unable to find any valid WPA handshakes in your file". Anyone got the same issues and know how to resolve it ? Or maybe an alternative for collecting handshakes?
×
×
  • Create New...