Jump to content

Unauthed

Active Members
  • Posts

    14
  • Joined

  • Last visited

Recent Profile Visitors

716 profile views

Unauthed's Achievements

Newbie

Newbie (1/14)

  1. Nice one hak5 team!! Two questions... 1) what is the internal storage and 2) can you connect a usbc flash drive into the charging port for additional storage? The use case I am thinking is capturing and storing creds with responder.
  2. Yes that works! Thanks! Now if i can get https://github.com/n3d-b0y/PMKIDAttack working I will be good to go. Thanks for your help.
  3. Unfortunately none of the modules are installing dependencies. I am on 2.6.0. Such as SiteSurvey etc.
  4. Any update on the fixed firmware? I have an engagement on Monday so would be keen to get it up and running prior. If it's unlikely by then I will downgrade.
  5. Works well for me, and my colleagues Tetra also. Are you running the latest build? If so, try doing it straight after a reboot to ensure another process isnt using wlan1. I had your error on Wlan0, but Wlan1 is fine. Let me know how you go...
  6. One of the biggest gaps I have found with the pineapple is the inability to perform hostapd-wpe type attacks. Thankfully, there is a OperWRT package for hostapd-wpe that seems to work very well... I just wanted to share in case anybody else needed the Pineapple to do this also.... ssh to your pineapple... ######## cd /tmp wget https://github.com/TarlogicSecurity/hostapd-wpe-openwrt/raw/master/packages/ar71xx/generic/hostapd-wpe_2014-06-03.1-1_ar71xx.ipk opkg install ./hostapd-wpe_2014-06-03.1-1_ar71xx.ipk ###### The configuration files are in /usr/local/etc/hostapd-wpe I changed the wifi to wlan1 and executed with hostapd-wpe ./yourconfig.conf Unfortunately I havent had the time to create a gui for it... I would love to see this integrated into PineAP functionality at some point... but until then, I hope somebody has the time and passion to wrap a GUI around it!! Hope this helps somebody out.
  7. Not sure if this will help... but I have created a little wrapper that uses aireplay to fake association when "do not associate with AP" is selected in advanced options. simply create a new file called "reaver" in /usr/bin/pineapple and set its executable permission by "chmod +x /usr/bin/pineapple/reaver Then cut and paste the following into the new file. Thankfully reaver is not executed by the wps module with a specific path, so it will pick up our script first: #!/bin/bash while getopts "Ai:b:e:c:" opt; do case $opt in A) NOASSOC=true;; c) CHAN=$OPTARG;; i) IF=$OPTARG;; b) BSSID=$OPTARG;; e) ESSID=$OPTARG;; esac done if [ $NOASSOC = true ] ; then iwconfig $IF channel $CHAN aireplay-ng -1 0 -e $ESSID -a $BSSID $IF fi /usr/bin/reaver "$@"
  8. When using reaver manually, I have had a lot of success using aireplay-ng first to fake the association, then use reaver to launch the attack. Also just came across this link recently: http://techsolutionsite.blogspot.com.au/2016/03/solution-for-warning-failed-to.htmlnot sure if that helps.
  9. Thanks Smarty! You are right... they were terrible even on the Alfa's... and yes, they were from a chinese eBay shop :) Next time I will not be so tight :)
  10. OK... I just upgraded mine with four 9db antennas, and I am getting significantly worse results than with my stock antennas... txpower is at 30.... is there something I need to do, or should I only upgrade two of them? Perhaps I bought some dud ones :(
  11. Thanks Sebkinee! In my silly attempt at troubleshooting i forced client wifi to wlan0 and now pineAP has stopped working... looks like it will be a factory reset :(
  12. Hi all, Hoping somebody could help me... I was hoping to use my Tetra to have one radio running PineAP and the other radio connected to the network via WIFI Client Mode. Unfortunately the only option I have under client mode is WLAN1 which is says will impact PineAP. I have confirmed that WLAN0 exists and that I can use it for monitor mode etc. Any ideas? Is what I am wanting to do possible? (I would of thought that was a standard use case). Cheers!!!
  13. Same issue here with wash, however wifite.py works perfectly. Perhaps use that to determine your target?
  14. I just thought i'd share my experiences with battery packs. Interesting issue where I am using two 50000mah 2.1A from one Y cable into UART boots the Pineapple OK, but then when trying to scan it reboots the Pineapple. However.... When I do the same thing into ETH the device happily work perfectly, uptime so far of over 2hrs while using Site Survey , capturing and deauth with no issues. Is this expected behaviour of UART vs ETH?
×
×
  • Create New...