Jump to content

twenty

Active Members
  • Posts

    9
  • Joined

  • Last visited

Recent Profile Visitors

696 profile views

twenty's Achievements

Newbie

Newbie (1/14)

  1. O.k. I figured that captive portals were so common that there must be an existing solution to this issue.
  2. Hi Zarabyte -- The video covers the simple case when all that is needed is a password for the wifi. In my case, and in many hotel setups, there is a secondary web page that is displayed. This secondary web page asks for a username/password, a ToS box to be checked, the webform submitted before the user is allowed on to the network. So that video sadly did not help.
  3. Thanks for replying. I very much appreciate it. Great, happiness! A tab for available infusions! Argh. Unhappiness "Error connecting. Please check your internet connection!" [my frustration: This combined with another earlier problem has meant that I have been at this for 2+ hours without being able to actually use the pineapple successfully] How to fix this? Lets try the Network link. I click on client. Scan for networks..... looking good. Argh.... Unhappiness. This network is one of those networks which requires the user: enter a username/password click a "I agree to the TOS" to complete the connection. The wifipineapple connects but doesn't let me complete the connection sign on. How to get the pineapple to show the login completion / or save the configuration to do so automatically? (preferred) How to get the pineapple to borrow the attached computer's connection? I feel like: http://demotivators.despair.com/demotivational/mistakesdemotivator.jpg Thanks for your help... Hopefully this will also help others as well. P.S. I feel like this should be part of the basic getting started guide which I am sure is around here ... some where?
  4. Hi there I am trying to find and understand infusions. I google wifipineapple.com infusions. Oh happiness, I see this page: https://wifipineapple.com/?infusions Awesome a list of infusions. No, wait. Unhappiness. There is just a list of infusions. Where is the actual code? Maybe if I go look at the forum there will be a list of infusions? Oh happiness, I see this page: https://forums.hak5.org/index.php?/forum/79-mark-v-infusions/ No, wait. Unhappiness. No infusion code here. ***WHERE ARE THE ACTUAL INFUSIONS???*** Seriously, Hak5 - Google can't find the wifipineapple infusions. Where can I find the infusions?
  5. UART ( For anyone else with this same problem ) : http://wiki.wifipineapple.com/index.php/Serial_UART
  6. What should I have done? Ctrl-D ? Why is the sysupgrade taking anything from <stdin> when the image was on the command line.
  7. Well I don't know what I did but... power cycled. Did factory reset with DIP switches powercycled put DIP normal mode power cycled put just DIP#5 in down position power cycled each time i left the power on for a few minutes Finally, in the DIP #5 off position, the mkv lights started blinking in the happy pattern.... and I could connect and do the initial upgrade to 2.0.2 version. But how come the sysupgrade wanted to take the input from the stdin? What is the UART?
  8. I have had the MKV for only a few days. (i.e. brand-new, not abused, etc.) Today I upgrade from the factory flash to 2.0.2. This was successful. I then noticed that there was a 2.0.3 version available. I downloaded this and checked the md5. I decided to do the upgrade via ssh. Per the instruction I then did the sysupgrade command: sysupgrade -n -v /tmp/upgrade-2.0.3.bin Sending TERM to remaining processes ... atd crond nginx php-fcgi-daemon sh php-fcgi dnsmasq ntpd sleep syslogd klogd hotplug2 ubusd mobile-keepaliv netifd Sending KILL to remaining processes ... ntpd sleep Switching to ramdisk... Performing system upgrade... Unlocking firmware ... Writing from <stdin> to firmware ... [w] [w] [w]^C @Pineapple:/tmp# writing from <stdin> was NOT what was expected. Figuring that the best solution was to power cycle and if needed to a factory reset. Thats what I tried. Unfortunately, I have not been able to do the factory reset: I powered off. Set DIP#5 in the down position. Powered on. All lights lit. Then just green and red. plugging in the ethernet cable got the a self-assigned ip message. and the yellow light... but no connection I set ifconfig en0 inet 192.168.1.2 - unsuccessful Then I tried ifconfig en0 inet 172.16.42.2 So this meant I could not use the web ui. Next I tried the Factory DIP switch factory reset: ( http://wiki.wifipineapple.com/index.php/Factory_Reset ) Now I just get just the red and green lights. And now no yellow light. Additional info: I am using the right power supply. ( i also tried the battery as well ) the ethernet cord is the brand-new ethernet cable that the mkv shipped with.
×
×
  • Create New...