Jump to content

Catware

Active Members
  • Posts

    12
  • Joined

  • Last visited

Recent Profile Visitors

282 profile views

Catware's Achievements

Newbie

Newbie (1/14)

  1. Would using wlan0 as client mode help? Meaning, is wlan1 not arp capabble and wlan0 is?
  2. Even declaring the router, no traffic. Or if I try to use a filter, no results, It's like it's not arping the network...
  3. I'm using wlan1 because that's what's connected to my home router. I want to MITM my home router, so it would be something like: Without ettercap: Pineapple & other devices -> Home router With: Other devices -> Pineapple -> Home router Since the connection between the router and the pineapple are using wlan1, shouln't I use wlan1 with ettercap? I think that br-lan would be to MITM the clients connected to the pineapple? Please correct me if my logic is incorrect. And thank you for the feedback, I've tried to use br-lan, but It did not work.
  4. Sure :) root@Pineapple:~# ifconfig br-lan Link encap:Ethernet HWaddr 00:13:37:A5:0C:10 inet addr:172.16.42.1 Bcast:172.16.42.255 Mask:255.255.255.0 UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:14982 errors:0 dropped:56 overruns:0 frame:0 TX packets:16819 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:1672082 (1.5 MiB) TX bytes:5280980 (5.0 MiB) eth0 Link encap:Ethernet HWaddr 00:13:37:A5:0C:10 UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:13635 errors:0 dropped:0 overruns:0 frame:0 TX packets:15926 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:1752550 (1.6 MiB) TX bytes:3935375 (3.7 MiB) Interrupt:4 lo Link encap:Local Loopback inet addr:127.0.0.1 Mask:255.0.0.0 UP LOOPBACK RUNNING MTU:16436 Metric:1 RX packets:540 errors:0 dropped:0 overruns:0 frame:0 TX packets:540 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:40376 (39.4 KiB) TX bytes:40376 (39.4 KiB) wlan0 Link encap:Ethernet HWaddr 00:13:37:A5:0C:10 UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:1620 errors:0 dropped:0 overruns:0 frame:0 TX packets:2466 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:198535 (193.8 KiB) TX bytes:1577990 (1.5 MiB) wlan1 Link encap:Ethernet HWaddr 00:13:37:89:85:36 inet addr:192.168.1.93 Bcast:192.168.1.255 Mask:255.255.255.0 UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:4444 errors:0 dropped:85 overruns:0 frame:0 TX packets:7556 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:2041821 (1.9 MiB) TX bytes:595424 (581.4 KiB)
  5. Yes, ipforward is enabled, I've checked and nothing happens. I arp the network, do urlsnarf -i wlan1, and no traffic
  6. Anyone? I still can't arp any network... Is wlan1 capable of arp-poison? Any lights on what I'm doing wrong would be great, I'm able to arp with my PC but would love to be able to do it on my pineapple!
  7. Hello everyone, I'm having a problem with how to use ettercap on the pineapple. I have my pineapple connecting to my router with wlan1, I then use: ettercap -i wlan1 -M arp // // -Tq and in another window urlsnarf -i wlan1 But the pineapple does not seem to be arping nor sniffing anything... Can anyone give me a hint to what am I doing wrong?
  8. Hello everyone, I'm having a problem with how to use ettercap on the pineapple. I have my pineapple connecting to my router with wlan1, I then use: ettercap -i wlan1 -M arp // // -Tq and in another window urlsnarf -i wlan1 But the pineapple does not seem to be arping nor sniffing anything... Can anyone give me a hint to what am I doing wrong?
  9. Not sure If I'm doing something wrong but what I did was: Uninstall sslstrip Format SD Update After the update I installed the bar update and sslstrip infusion reapears (along with a few others (which shouldn't happen since I formated the sd?)) and I'm able to start sslstrip, but after that the network just blocks everything that is not ssl instead of sslstriping... It's the same issue I had when I stopped sslstrip without a reboot, it would block every traffic that is not https. Am I doing something wrong?
  10. Thank you for the explanation! Nice to have some feedback. So the yagi is very directional... Maybe not the best option I guess. What would be the appropriate antenna dbi to increase your range without sacrificing on the "direction"? I'm saying this because, if I check my signal strength, even if I leave my pineapple in one room and move to the next one is very low compared to my home router for instance. Seems that the stock antennas are for close-quarter pentesting.. :)
  11. I'm still very newb so I'm sorry for the silly questions, but, I have my eye on a yagi someone near me is selling. The antenna is 2.4ghz and made for wifi use, 25dbi. the connector is sma. Can I connect the antenna directly to the pineapple? Should I have an amplifier between the antenna and the pineapple or is this optional? Also, do I need to change anything on the pineapple after I install the antenna?
  12. Edit: I only get this problem if I install on the sd, internal I get the same problem everyone seems to have, it works, but if you stop it, then only ssl websites work and you need to restart the pineapple... I'm getting this after reinstalling sslstrip. I'm on 1.0.1, Traceback (most recent call last): File "/sd/usr/bin/sslstrip", line 30, in <module> from sslstrip.StrippingProxy import StrippingProxy ImportError: No module named sslstrip.StrippingProxy
×
×
  • Create New...