Jump to content

EightBall

Active Members
  • Posts

    5
  • Joined

  • Last visited

Recent Profile Visitors

439 profile views

EightBall's Achievements

Newbie

Newbie (1/14)

  1. So I got it working somehow, not too sure exactly what I did. All I can deduce is that I connected to an open network in client mode with the network tile, which worked, then connected to an auth required network which worked after that.
  2. okay so doing more digging - I've tried using the built-in network tile and I get the same behavior - I try to connect in client mode - the connection doesn't happen. If I go back to the main network tile and do a refresh it says that wlan1 is now disabled. Doing ifconfig shows that wlan1 is gone. I run "ifconfig wlan1 up" it comes back and doing a new refresh on the network tile again shows it as enabled. I go through the same process again and wlan1 gets disabled as before. I started trying to use wifi-manager because I couldn't get the built-in network tile to work. Also I've never seen the red led (wlan1) turn on except quick flashes during boot or factory reset. Here's the /etc/config/wireless after trying to use the network tile. root@Pineapple:~# cat /etc/config/wireless config wifi-device 'radio0' option type 'mac80211' option channel '11' option hwmode '11ng' option macaddr '00:13:37:**:**:**' option htmode 'HT20' list ht_capab 'SHORT-GI-20' list ht_capab 'SHORT-GI-40' list ht_capab 'RX-STBC1' list ht_capab 'DSSS_CCK-40' option disabled '0' config wifi-iface option device 'radio0' option network 'lan' option mode 'ap' option ssid 'Guest Network' option hidden '0' config wifi-device 'radio1' option type 'mac80211' option hwmode '11g' option macaddr '00:13:37:**:**:**' option channel '6' option disabled '0' config wifi-iface option device 'radio1' option ssid 'Test' option mode 'sta' option hidden '0' option network 'wan' option encryption 'psk2+ccmp' Here's my ifconfig output before and after. br-lan Link encap:Ethernet HWaddr 00:13:37:**:**:** inet addr:172.16.42.1 Bcast:172.16.42.255 Mask:255.255.255.0 UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:10018 errors:0 dropped:44 overruns:0 frame:0 TX packets:10472 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:1027580 (1003.4 KiB) TX bytes:4418408 (4.2 MiB) eth0 Link encap:Ethernet HWaddr 00:13:37:**:**:** UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:21983 errors:0 dropped:0 overruns:0 frame:0 TX packets:18329 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:17195808 (16.3 MiB) TX bytes:5100672 (4.8 MiB) Interrupt:4 lo Link encap:Local Loopback inet addr:127.0.0.1 Mask:255.0.0.0 UP LOOPBACK RUNNING MTU:16436 Metric:1 RX packets:544 errors:0 dropped:0 overruns:0 frame:0 TX packets:544 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:40269 (39.3 KiB) TX bytes:40269 (39.3 KiB) wlan0 Link encap:Ethernet HWaddr 00:13:37:**:**:** UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:1955 errors:0 dropped:0 overruns:0 frame:0 TX packets:3423 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:149519 (146.0 KiB) TX bytes:4305874 (4.1 MiB) running ifconfig wlan1 up adds wlan1 adapter and shows wlan1 enabled on the network tile - same output as above except with the wlan1 adapter at the end wlan1 Link encap:Ethernet HWaddr 00:13:37:**:**:** UP BROADCAST MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:0 (0.0 B) TX bytes:0 (0.0 B) dmesg shows virtually no wlan1 info root@Pineapple:~# dmesg | grep wlan1 [ 3.630000] Registered led device: mk5:red:wlan1
  3. I don't have ICS enabled. Here's the config file after doing a factory reset, running the commands jdoe suggested, updating, then configuring wifi via wifi manager. config wifi-device 'radio0' option type 'mac80211' option channel '11' option hwmode '11ng' option macaddr '00:13:37:**:**:**' option htmode 'HT20' list ht_capab 'SHORT-GI-20' list ht_capab 'SHORT-GI-40' list ht_capab 'RX-STBC1' list ht_capab 'DSSS_CCK-40' option disabled '0' config wifi-iface option device 'radio0' option network 'lan' option mode 'ap' option ssid 'Guest Network' option hidden '0' config wifi-device 'radio1' option type 'mac80211' option hwmode '11g' option macaddr '00:13:37:**:**:**' option channel '6' option disabled '0' config wifi-iface option device 'radio1' option network 'lan' option ssid 'Test' option mode 'sta' option hidden '0' option encryption 'psk2+tkip+aes'
  4. thanks for the suggestion, but I tried it and it doesn't work
  5. When I turn on both wlan interfaces and turn one on for client mode (wlan1) set the pre-shared key, save and then commit - after I commit the changes the client (wlan1) interface becomes disabled and the pre-shared key field is blank. Radio0 is still enabled but no longer linked to wlan1. Wlan0 and radio1 is still turned on. I've tried doing a factory reset and only configuring client mode and it still exhibits the same behavior. I'm trying to create an access point on one interaface and internet connection share the client connected interface that's connected to my mobile device. Maybe I'm missing something? Is what I'm trying to accomplish not possible? I'm fully updated and using Wi-fi Manager to configure the interfaces.
×
×
  • Create New...