Jump to content

rockstargroover

Active Members
  • Content Count

    20
  • Joined

  • Last visited

About rockstargroover

  • Rank
    Hak5 Fan

Recent Profile Visitors

439 profile views
  1. So I'm using the PineAP over cli and I'm trying to start a general deauth going. This is what's happening: What am I doing wrong?
  2. I'm having the same issue as well. I can't get any of the 5 PineAP attacks to stay checked and I refreshed after starting and it brings back no intelligence report.
  3. I have an idea. Let's get an infusion running that takes reaver, ettercap, ssl strip, with sms notifications. Let's take the known script wifite.py put that in perspective. In that manner use reaver to target the closest and strongest SSID, and run until a successful PIN has been detected. Once reaver has found the PIN there should be a way to automatically connect to the target SSID AP via client mode and start ettercap and ssl strip for a set length of time in the parameters of the infusion. Once the script has finished it should send an SMS or some kind of notification with a log.
  4. Thank you so much for your help. It works. ssh -p 9999 root@externalip -L 9090:localhost:1471 Awesome. That there, is the magic.
  5. Well like I said I'm not trying to do it through putty. I am sshing through the relay to the pineapple from an ubuntuvm or kali vm. But I'll set up the putty just for this exercise. Edit: Also why am I using 9090? Shouldn't there be a -R or -L in that argument??
  6. Good News! I'm able to ssh through -p 9999 directly to the pineapple through the relay server. Now I don't really care about putty so much but being able to access the gui is my next step.
  7. After doing netstat -na | grep 9999 this is what I get. root@relayserverVM:~# netstat -na | grep 9999 tcp 0 0 0.0.0.0:9999 0.0.0.0:* LISTEN tcp6 0 0 :::9999 :::* LISTEN
  8. Ok where is the connections profile located? Are you talking about the SSH config file /etc/init.d/sshd_config?
  9. Ok I specified "Port: 9999" on the Autossh config. Then I opened external port 9999 to point to 9999 internal port for 192.168.1.234 (server). This is the log I have after having all these settings: Pineapple Host: root@externalip -p 7000 Port: 9999 Remote Port: 1471 Port Forwards on Router: External: 7000 Internal: 22 to 192.168.1.234 External: 9999 Internal: 9999 to 192.168.1.234 Now after clicking autossh connect I have these logs: Jan 18 20:48:01 Pineapple auth.info sshd[5269]: WARNING: /etc/ssh/moduli does not exist, using fixed modulus Jan 18 20:41:54 Pineapple user.info autos
  10. Now what do you mean by this though specifically? I need to specify an external port for the "Remote Port: " or the "Port: "? Yes I can ssh from my phone, my virtual ubuntu, and any of my devices from anywhere to my relay server.
  11. Yes if I do everything through the LAN it works fine. I can access the GUI through the relay server through the LAN. It's externally that it doesn't work. I've read some other threads and found that the AutoSSH tile is broken and you have to set a command on a dip switch so that it works. So how about we compile a command for autossh that I can execute on a dipswitch.
  12. So I have some new logs here: Jan 18 18:28:52 Pineapple user.info autossh[2249]: ssh child pid is 3301 Jan 18 18:28:52 Pineapple user.info autossh[2249]: starting ssh (count 2) Jan 18 18:28:52 Pineapple user.info autossh[2249]: port down, restarting ssh Jan 18 18:28:52 Pineapple user.info autossh[2249]: timeout polling to accept read connection Jan 18 18:18:37 Pineapple user.info autossh[2249]: ssh child pid is 2250 Jan 18 18:18:37 Pineapple user.info autossh[2249]: starting ssh (count 1) To verify I can ssh to my relay server from putty and an ubuntu VM through "ssh -p 7000 root@externalip"
  13. I ssh just fine into the relay server as root but I'll try setting a different user to ssh into with. Ok so let me get this straight. I have to have an external port for each of these ports: Relay Server SSH 22 Pineapple Port 9999 Or do I make port 9999 the external port for the 1471 remote port on my router?
  14. Here is a log from today when trying my autossh. Jan 18 06:12:16 Pineapple user.err autossh[2029]: ssh exited prematurely with status 255; autossh exiting Jan 18 06:12:15 Pineapple user.info autossh[2029]: ssh child pid is 2030 Jan 18 06:12:15 Pineapple user.info autossh[2029]: starting ssh (count 1) Here is my autossh config Host: root@externalip Port: 7000 Listen Port: 22 My relay server is set for: -p 7000 root@externalip I can ssh just fine with ssh -p 7000 root@externalip -i /etc/dropbear/id_rsa But I'm trying to figure out why I'm getting this error.
  15. I'll have to try this out. My only question is I can't specify -p on autossh on my pineapple when inputting for the user@host. Also I just have my router external port forwarding directly to my VM which is bridged to my nic. What I'm saying is that I should be able to manage the gui by relay server. I have tested it internally and it works (not by hitting external IPs). But what if I want send information back to the gui port 1471? All my SSH is routing through -p 7000 to 22 internal. But I'm trying to replicate chriswhat's tutorial on managing the gui externally.
×
×
  • Create New...