Jump to content

Oli

Active Members
  • Posts

    237
  • Joined

  • Last visited

  • Days Won

    4

Posts posted by Oli

  1. I don't have my pineapple with me at the moment, but here is the content of the relevant files from a backup I made the other day (with sensitive information changed):

    network:

    # Copyright (C) 2006 OpenWrt.org
    
    config interface loopback
    	option ifname	lo
    	option proto	static
    	option ipaddr	127.0.0.1
    	option netmask	255.0.0.0
    
    config interface lan
    	option ifname	eth0
    	option type 	bridge
    	option proto	static
    	option ipaddr	172.16.42.1
    	option netmask	255.255.255.0
    	option gateway  172.16.42.42
    	option dns	8.8.8.8
    
    config interface wan
    	option ifname wlan1
    	option proto dhcp
    
    config interface usb
    	option ifname usb0
    	option proto dhcp
    
    config interface wan2
    	option ifname ' '
    	option proto ' '
    	option service ' '
    	option device ' '
    	option apn ' '
    	option username ' '
    	option password ' '
    	option defaultroute ' '
    	option ppp_redial ' '
    	option peerdns ' '
    	option dns ' '
    	option keepalive ' '
    	option pppd_options ' '
    
    

    Wireless:

    config wifi-device 'radio0'
    	option type 'mac80211'
    	option channel '11'
    	option hwmode '11ng'
    	option macaddr '00:13:37:xx:xx:xx'
    	option htmode 'HT20'
    	list ht_capab 'SHORT-GI-20'
    	list ht_capab 'SHORT-GI-40'
    	list ht_capab 'RX-STBC1'
    	list ht_capab 'DSSS_CCK-40'
    
    config wifi-iface
    	option device 'radio0'
    	option network 'lan'
    	option mode 'ap'
    	option ssid 'Pineapple5_xxxx'
    	option encryption 'none'
    
    config wifi-device 'radio1'
    	option type 'mac80211'
    	option channel '11'
    	option hwmode '11g'
    	option macaddr '00:13:37:xx:xx:xx'
    
    config wifi-iface
    	option device 'radio1'
    	option mode 'sta'
    	option network 'wan'
    	option ssid 'hello'
    	option key 'world'
    	option encryption 'mixed-psk+ccmp'
    
    
    
  2. OK, so now I can't even client mode connect to open networks - even after a 'factory reset'.

    Addtionally, even attempting to client mode connect to any network kills the Pineapple5_xxxx access point and it doesn't work again until I do another factory rest.

    Something doesn't seem right to me...

    Are there any diagnostics I can run to make sure both radios are working properly and/or make sure that a factory reset is working properly?

    I tried the WiFi Manager infusion and couldn't get things working either! Is anybody else having issues or is it just me?

  3. Can we have the MKV web interface on Github and make it a GPL project? Now that it is out of "secret" mode (and using a custom board) it would be nice to be able to keep track of developments and be able to contribute back to the official code line (or fork it and implement some of my crazy ideas). Additionally, it would be nice to have infusions open sourced, where the author is happy with this.

    From my point of view, the MKV opens up some exciting possibilities and I'd like to get more involved with enhancing some of the core functionality rather than just contributing infusions.

    Additionally, can we have the process for deploying a web interface on the pineapple documented? Suppose I have a patched/customized web interface that I want to use (or if we make it a Github project and head revs are pulled), how can I deploy the code in such a way as not to break the 'restore' functionality and brick the thing! I know it is 'un-brickable' but I have a habit of breaking things! :)

    Are there any gotchas that we should be aware of with customizing the web interface?

×
×
  • Create New...