Jump to content

BAHansen.us

Active Members
  • Posts

    35
  • Joined

  • Last visited

About BAHansen.us

  • Birthday 10/12/1975

Contact Methods

  • Website URL
    http://bahansen.us
  • Skype
    bahansen.us

Profile Information

  • Gender
    Male
  • Location
    Detroit

Recent Profile Visitors

1,051 profile views

BAHansen.us's Achievements

Newbie

Newbie (1/14)

  1. I've found some of the best deals on Ebay and buying from China: Connectors http://www.ebay.com/itm/281103061197?ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1497.l2649 I bought 2 straight, 2 90 degree elbows with shipping it was less than $10.00. Great quality. Antennas: http://www.ebay.com/itm/300949768340?ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1497.l2649 http://www.ebay.com/itm/151115334343?ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1497.l2649 I found a Yagi antenna for less than $10, but the item is no longer there. The range on these are insane. I now have a full collection for the Pineapple and spent less than $45. It takes some time for shipping, but well worth the wait.
  2. Darren, I've been thinking about this for a bit. My first Pineapple is the Mark V. I've done some initial testing just to see how often clients will connect to the Mark V. I was at a busy coffee shop and was blown away at the number of clients that associated to the Mark V. It put such a load on the Mark V I could barely access the web interface. With the above solution, would it offset some of the processing to the Mark IV? I know traffic would still need to be routed via Ethernet port, but does it take less processing power? Spreading infusions between the two Pineapples would most definitely speed things up. Thoughts? I just might have to get another Mark V, or Mark IV. :-)
  3. A PirateBox shouldn't be too hard: http://wiki.daviddarts.com/PirateBox_DIY
  4. Amazon has them for CHEAP! http://www.amazon.com/Super-Power-Supply%C2%AE-WRTU54G-TM-WRT54G-TM/dp/B00CPAAHIS/ref=sr_1_2?ie=UTF8&qid=1384227796&sr=8-2&keywords=poe+adapter
  5. Thank You Seb! True opensource collaboration on this one!!
  6. macchanger requires the device argument to run (wlan1|wlan0), and the only way I could figure out how to get it to work was to assign the MAC to the device, then extract the MAC into a variable. The time that is being used up is bringing the devices down, and then back up. If that wasn't necessary the script would be pretty fast. Good Job!
  7. I got this one figured out. The problem I was running into is when I would run the following code the power of the radio's were at their MAX. With a little reading I found out that OpenWRT always defaults to MAX power. However, trying to change the power to anything else didn't work for me using "iwconfig wlan0 txpower 29" The settings were just ignored. The following code works for me: uci set wireless.@wifi-device[0].country=BO uci set wireless.@wifi-device[0].txpower=24 uci set wireless.@wifi-device[1].country=BO uci set wireless.@wifi-device[1].txpower=29 uci commit wireless wifi
  8. jjd - There we go, that was it. Thank you!! Needed to change iface not device!! In theory: ifconfig wlan0 down macchanger -r wlan0 ifconfig wlan0 up wlan0_MAC=$(ifconfig wlan0|grep -o -E '([[:xdigit:]]{1,2}:){5}[[:xdigit:]]{1,2}') uci set wireless.@wifi-iface[0].macaddr=$wlan0_MAC;uci commit wireless wifi The two processes could of-course be combined. I've also been trying to work on custom power settings. I've been on this other thread https://forums.hak5.org/index.php?/topic/30748-txpower-woes/ Think I got this figured out as well: uci set wireless.@wifi-device[1].country=BO uci set wireless.@wifi-device[1].txpower=29 uci commit wireless wifi I want to increase the power of my WiFi without running at full power. I've read that it can cause serious heat problems, so I want to run at almost full power. Problem with just changing the region code to "BO" by using "iw reg set BO" is OpenWRT defaults to FULL power. All these features could be added to the WiFi Manager...
  9. jjd - The "uci set wireless..." essentially does the same thing. It just is a more elegant way than directly modifying the /etc/config/wireless file. Note: I have use the "wifi detect > /etc/config/wireless" to reset the settings after each run. I've manually modified the /etc/config/wireless to change the MAC address, when I run wifi the following error comes up root@Pineapple:/etc/config# wifi PHY for wifi device radio1 not found PHY for wifi device radio1 not found This does seem normal because it doesn't match /sys/class/ieee80211/phy1/macaddress However, packets still don't seem to route from wlan0 through wlan1 Also, when I restart it adds another radio Before Reboot: (Note this does not have the information to connect to my Cable router) config wifi-device radio1 option type mac80211 option channel 11 option hwmode 11g option macaddr 00:00:00:00:00:11 # REMOVE THIS LINE TO ENABLE WIFI: # option disabled 1 config wifi-iface option device radio1 option network lan option mode ap option ssid Pineapple5_424A option encryption none After Reboot: config wifi-device radio1 option type mac80211 option channel 11 option hwmode 11g option macaddr 00:00:00:00:00:11 # REMOVE THIS LINE TO ENABLE WIFI: # option disabled 1 config wifi-iface option device radio1 option network lan option mode ap option ssid Pineapple5_424A option encryption none config wifi-device radio2 option type mac80211 option channel 11 option hwmode 11g option macaddr 00:13:37:81:42:4a # REMOVE THIS LINE TO ENABLE WIFI: # option disabled 1 config wifi-iface option device radio2 option network lan option mode ap option ssid Pineapple5_424A option encryption none jjd - is this happening to you?
  10. In the above script i'm assigning a random MAC address. I just tried: uci set wireless.@wifi-device[1].macaddr=00:00:00:00:00:11;uci commit wireless And I have the same problems. The above method is supposed to work with OpenWRT. I'll be trying your script next, just thought this should work. Thank You!
  11. Good Day All, JJD - Your script looks good. I'm going to give it a try next. I've been working on the same problem, but seem to be running into two problems. Right now i'm focused on only wlan1 as I'm connecting through the AP. This is what I've come up with: #!/bin/sh # Assign Random MAC # B.A. Hansen # ifconfig wlan1 down macchanger -r wlan1 ifconfig wlan1 up wlan1_MAC=$(ifconfig wlan1|grep -o -E '([[:xdigit:]]{1,2}:){5}[[:xdigit:]]{1,2}') uci set wireless.@wifi-device[1].macaddr=$wlan1_MAC;uci commit wireless wifi However I have few problems 1) When I execute the wifi command it returns the following error: PHY for wifi device radio1 not found Based on my reading this occurs becuase the MAC I assigned doesn't match the value in /sys/class/ieee80211/phy1/macaddress and shouldn't be a problem. 1) However, even though it shows that I'm connected to my wireless router with a IP, packets don't seem to be routing from the Pineapple AP to the WiFi Connection 3) When I reboot the system gets confused and creates a second wireless entry in /etc/config/wireless Thoughts?
  12. Foxtrot, Great infusion, worked great!!
  13. Good Day All, I've been working adjusting the power of my AP wlan0. I've had good luck increasing the power by simply changing the region setting to Bolivia "iw reg set BO" Then adjusting the power to something higher than the default 18 dBm "ifconfig wlan0 down" "iwconfig wlan0 txpower 25" "ifconfig wlan0 up" This didn't do much for me because the AP did not come backup, and the blue light didn't turn back on. From reading other posts I understand that I must also run the "wifi" command. This worked great and brought up both wlan0 and wlan1. However, once I changed the region code to "BO" the power on both wlan1 and wlan0 MAXED. wlan0 = 27 wlan1 = 30 I've been doing some reading and I actually do not want to run on full power all the time. I would like granular control over the settings. I would much rather run my wlan0 at 25 dBm, and leave wlan1 at 27dBm. It appears that the "wifi" command sets the power to the max depending on the region. I've looked through the script and don't see anything obvious that adjusting the settings. Is there a way to bring down wlan0 adjust the power settings and bring it back up without running the "wifi" command? I must be missing something somewhere. Note: I also tried " "iwconfig wlan0 txpower 25dBm" with not difference. Both commands appear to be accepted. Thank You
×
×
  • Create New...