Jump to content

theVoiD

Active Members
  • Posts

    3
  • Joined

  • Last visited

Recent Profile Visitors

393 profile views

theVoiD's Achievements

Newbie

Newbie (1/14)

  1. That worked! Thank You so much! I love You man! Thanks to inTheDMZ too :) It was not just plain stupidity but rather ignorance on my side. I still don't quite get how iptables and NAT works but I am going to read that up, I promise! =) Now I am fighting with making this rule persistent and to create an exception for the printer's IP :) I'll keep You posted ^_^
  2. I supposed, that this would be only an optional line, in case other servers should provide DNS-functions. I changed it as You recommended. Also I tried to provide the DNS-Server of our TeleComm-Provider, just in case. I also tried only offering SVR5 or the router as DNS-Server by commenting the other lines out. None did work. I also checked the routes in the client. It showed 192.168.178.1 as Gateway once and 192.168.176.1 the other time. Both times no connection to the internet. But I can always reach SVR5 via SSH and the config-page from the client as well as from any clients connected to the Fritz-Modem(/Router). The config Page (accessed via ethernet-cable on eth0) shows this (followed by one of the configs I tried for dhcp): ## DHCP config 'dnsmasq' option 'domainneeded' '1' option 'boguspriv' '1' option 'filterwin2k' '0' option 'localise_queries' '1' option 'rebind_protection' '1' option 'rebind_localhost' '1' option 'local' '/lan/' option 'domain' 'lan' option 'expandhosts' '1' option 'nonegcache' '0' option 'authoritative' '1' option 'readethers' '1' option 'leasefile' '/tmp/dhcp.leases' option 'resolvfile' '/tmp/resolv.conf.auto' config 'dhcp' 'lan' option 'interface' 'lan' option 'start' '50' option 'limit' '150' option 'leasetime' '12h' option 'ignore' '0' list 'dhcp_option' '3,192.168.176.1' list 'dhcp_option' '3,192.168.178.1' list 'dhcp_option' '3,217.237.151.51' # list 'dhcp_option' '3,172.16.42.42' # list 'dhcp_option' '3,172.16.42.1' # list 'dhcp_option' '6,172.16.42.1,8.8.8.8' # list 'dhcp_option' '6,172.16.42.1,208.67.222.222' #config 'dhcp' 'wan' # option 'interface' 'wan' # option 'ignore' '1' # option 'start' '100' # option 'limit' '150' # option 'leasetime' '12h' # list 'dhcp_option' '3,172.16.42.42' # list 'dhcp_option' '6,172.16.42.1,8.8.8.8' # list 'dhcp_option' '6,172.16.42.1,208.67.222.222' They are just for general internet. I wanted to use pineapples instead of some random device in order to have them at ready to occasional use their features and to support hak5 of course. Also I didn't think that they wouldn't work in this setup. I would like to get the pineapples to work rather then sending them back especially as I suppose that I might run into the same problems with any other router based on OpenWRT (or even more, as pineapples at least come with it pre-installed). And how would I configure them to be dumb routers? And is there a reason why I couldn't do that with a pineapple? Also I really want to understand why it doesn't work.
  3. Hey! I'm trying to use 2 pineapples to provide wifi for two storeys of the same building (office with roundabout 10-15 persons each). I got them configured, they have access to the internet but they don't relay it to their clients (be it eth or wifi). Any clients connected to a pineapple can ping the pineapple only. traceroutes fail right after the pineapple (tried this for Macs and Win7/8-machines - also for an android phone - except for the traceroute-part of course). - I tried to correct the config files (/etc/config/ network, dhcp, wireless, firewall) - I tried to leave wide open the firewall (which isn't installed on a pineapple, if I understand correctly) - I flushed the iptables (iptables -F) - I tried setting the route: route add default gw 192.168.178.1 to no avail, even with a couple of restarts (barring the iptables which would be reestablished if I understood correctly). I tried a search, but except for this Post of computerchris I couldn't find anything. As I don't have any linux-machines at hand I couldn't start the wp4.sh-file from anywhere and the first of the iptables commands in the quote would give me the error that I may not use the -s parameter twice. The pineapples are connected to a switch (netgear) via ethernet, which in turn leads to the router (192.168.178.1 - 192.168.178.0/24) which also functions as a dsl-modem (Germany - Fritz Box 7390) and a wifi-router (I wanted to install the pineapples to give the network a cleaner layout and have the dsl-modem not do everything - well and also to play around with the pineapples whenever there is a chance ^_^). They can ping to anywhere in the internet, as well as to the dsl-modem. Also they can be reached from any station connected to the dsl-modem (being the wifi-router as well) or connected to the pineapple itself. Because I want to use the pineapples with only the ethernet-cable, I switched the devices in the network-config-file so that wan would lie on the poe-enabled port. The pineapples are supposed to connect to the dsl-router via dhcp and distribute via wifi and the former wan port; 192.168.177.0/24 (SVR6) and 192.168.176.0/24 (SVR5). I just received the devices and I tried all day to get them running. I am quite desperate. They run on 3.0 (SVR5) and 2.8.1 (SVR6 - I had to flash one of them as it almost bricked and then would not react to any changes in the config files). Both have the exact same problem. Albeit flashing the iptables and setting the routes I only tried on one of them (SVR5). I will post the config files at the end of the post for one of them (SVR5) and also attach the zip-files with the config-folders of both: SVR5.zip SVR6.zip Here a little map: Internet | DSL-Modem 192.168.178.1 | Switch | \ SVR5 SVR6 192.168.176.1 192.168.177.1 | \ clients clients I would like to configure them correctly - in order to have the clients get throught to the internet - to have a deeper understanding of the inner workings of openwrt and the pineapples I don't get anywhere on my own anymore. Please help and inform me about my mistakes. I am eager to learn =D contents of /etc/config/ network wireless dhcp firewall
×
×
  • Create New...