Jump to content

WideEyedAndClueless

Active Members
  • Posts

    20
  • Joined

  • Last visited

Recent Profile Visitors

621 profile views

WideEyedAndClueless's Achievements

Newbie

Newbie (1/14)

  1. In the end at the advice of InTheDMZ i swapped to an unlocked ZTE MF637 on 3UK PayG. And after a couple of reboots of the pineapple it connects up great. *19d2:0031*) echo "ZTE MF637 (3UK) detected. Attempting mode switch" uci delete network.wan2 uci set network.wan2=interface uci set network.wan2.ifname=ppp0 uci set network.wan2.proto=3g uci set network.wan2.service=umts uci set network.wan2.device=/dev/ttyUSB2 uci set network.wan2.apn=three.co.uk uci set network.wan2.defaultroute=1 uci commit network sleep 10; rmmod usbserial sleep 5; insmod usbserial vendor=0x19d2 product=0x0031 sleep 5; /etc/init.d/firewall disable; /etc/init.d/firewall stop logger "3G: firewall stopped" iptables -t nat -A POSTROUTING -s 172.16.42.0/24 -o 3g-wan2 -j MASQUERADE iptables -A FORWARD -s 172.16.42.0/24 -o 3g-wan2 -j ACCEPT iptables -A FORWARD -d 172.16.42.0/24 -m state --state ESTABLISHED,RELATED -i 3g-wan2 -j ACCEPT Big thanks to InTheDMZ for the advice and script.
  2. the last few entries are 21:39:45 Pineapple daemon.notice pppd[2281]: Modem hangup 21:39:45 Pineapple daemon.notice netifd: Interface 'wan2' is now down 21:39:45 Pineapple daemon.info pppd[2281]: Exit. 21:39:44 Pineapple daemon.notice pppd[2281]: Connection terminated. 21:39:38 Pineapple daemon.warn pppd[2281]: IPCP: timeout sending Config-Requests 21:39:05 Pineapple daemon.notice pppd[2281]: CHAP authentication succeeded The blue light on the dongle is still flashing, not solid blue. I tried connecting up through the pineapple with another computer but it got no internet access. The log just repeates the section i posted over and over, each time failing at "IPCP: timeout sending Config-Requests".
  3. @laputer:) i might just buy one to see if it works. @InTheDMZ : Thanks for that but still no joy im afraid. GifGaf and o2 are essentially the same carrier i think.
  4. Sure thing Can i ask what dongle / carrier you are using InTheDMZ? Seeing as you are also in the uk.
  5. Thanks imTheDMZ, I just tried plugging into a computer and it installs the drivers and connection manager and allows you to connect up no problems at all. I visited the link you provided and tried the solution (created a lock directory) to the problem they were having and there has been no change. Its still giving me: Pineapple daemon.warn pppd[2360]: IPCP: timeout sending Config-Requests after the CHAP authentication.
  6. II still havent been able to get the dongle working. Ive been looking through all the related posts on this forum and i haven't been able to find a good solution. Does anyone have any suggestions why this isn't working or how i can go about fixing it? Thanks
  7. Hi Darren thanks for the reply and sorry about not getting back to you sooner, its been a hectic week for me. This is the log i get if i start the pineapple with the dongle plugged in and the keep alive switched off If i have the keep alive setting switched on i get this section that repeats So after the line : 00:05:14 Pineapple daemon.notice pppd[2360]: CHAP authentication succeeded it waits about 30 seconds and times out with: 00:05:54 Pineapple daemon.info pppd[2360]: Exit. 00:05:53 Pineapple daemon.notice pppd[2360]: Connection terminated. 00:05:47 Pineapple daemon.warn pppd[2360]: IPCP: timeout sending Config-Requests this is the output from the commands you asked me to run :
  8. Hi, ive been trying to find a 3G dongle that works ok with the pineapple here in the UK and so far I haven't had much luck . I've got 2 Huawei 3G dongles one 160 and an unlocked E173 using a 'pay as you go' plan with O2 and neither of them seem to want to work correctly when plugged directly into my pineapple. I can see there is specific code in the Mobile broadband configuration script on the pineapple for the E173 so I'm not sure why its not connecting. I've got the pineapple plugged into the mains so there should be enough power going to it. I'm using firmware 2.8.1. I'm really not sure if it's an issue with the dongle or the carrier or both or even the pineapple. Does the carrier make much of a difference? Can anyone suggest anything or recommend a good setup? This part of my log gets repeated over and over after trying to force the connection:
  9. A really basic question here, as the Pineapple only has 1 USB socket I can't use a USB 3G dongle and have access to infusions installed to a USB flash drive. Is the solution just to get one of the powered USB hubs from the HakShop, and use it with an Anker battery unit? Has anyone done this?
  10. Great job on getting to the bottom of this problem and coming up with a fix Darren. Ive got my email saying the new USB's and cases have been sent out. Really great service
  11. I first noticed the issue with version 2.7.0 (if that's what they are shipped with at the moment) , i then upgraded the firmware and the problem was still there.
  12. Thanks for a quick response Shanon, i will stay tuned for more info. @ Mr Protocol : Thanks for the reply this is the reply i got from sandisk : The trouble is i have to send it to the Czech Republic to get a replacement. Probably going to cost me as much as a new one.
×
×
  • Create New...