Jump to content

bugsland

Members
  • Posts

    2
  • Joined

  • Last visited

Recent Profile Visitors

337 profile views

bugsland's Achievements

Newbie

Newbie (1/14)

  1. Another piece of info... When I run a TCPdump on the Pineapple I can see traffic but half is dropped: tcpdump -i wlan0 -n net 172.16.42.0/24 tcpdump: WARNING: wlan0: no IPv4 address assigned tcpdump: listening on wlan0, link-type EN10MB (Ethernet), capture size 65535 bytes 499 packets captured 1031 packets received by filter 532 packets dropped by kernel
  2. Hi everyone! I am a new Pineapple Mark IV user and so far enjoying the ride! :) I have a question about a strange problem I am having with my Pineapple, in a nutshell, I can connect to the Pineapple management portal, I have configured a tablet to connect to the pineapple wifi and it can access the internet. But on the Pineapple management portal if I click on upgrade or public_internet, I get a connection error... as if my laptop was not properly doing the ICS. Now for the details. I am using a Macbook pro (latest OS X), I have upgraded the Pineapple to version 2.7.5. I tried to connect the pineapple natively from my Mac, but had problems with ICS. I could connect to the management portal but the Internet connection could not be shared, no matter how much I tried using the help I found online (manual network setup, moving the network interface priorities, Internet Sharing option, etc). I stopped trying when I read there was a problem on Mac OS X ICS and that I should change my Pineapple IP address to something like 192.168.x.x. I am waiting to receive my Serial TTL cable before trying to change the IP! :) But... I could successfully configure it with running Backtrack 5 R3 on my Mac. Disabling the Ethernet connection natively on the mac, In VMware adding the Ethernet connection as a "Bridge" and the Wifi Internet connection as a "Bridge" too. Then running /etc/init.d/networking restart and wp4.sh everything worked fine. I was happy! :) I tried the tcpdump infusion and it worked, same for URLsnarf, dns spoofing... Karma... not so much, I get a very mixed result! (but I admit I am still a bit confused with the black/white list). anyway... that was last night! This morning... I am trying on another network (one I am allowed to try on). I could connect to the Pineapple management console but the internet connection on BT didn't worked at first! Meaning I could not get Backtrack to get an IP address for the Internet (through a WEP internet connection...yup...) I had to change from a Bridge to a NAT, this time it worked. BT had an internet connection. This is where it is odd... I cannot access the internet from the pineapple console! I tried resetting (many times) my pineapple, mac, vm, etc... still no luck... then I just tried to connect my test android tablet on the pineapple wifi just in case... and I can see I have internet access! So the question is: How come I seem to be sharing my internet connection through the Pineapple, but the pinapple cannot access the internet from the console (public_internet and pineapple bar)? what other troubleshooting can I do? I will try again tonight at home, but I need for it to work where I have been asked to test it. Thanks! Bugsland.
×
×
  • Create New...