Archived

This topic is now archived and is closed to further replies.

engineman

Remove/Replace non-U3 CD Partition from USB drive

125 posts in this topic

Nope, you will have to disassemble it and read the markings on the controller-chip ..

They probably had it custom-made somewhere, the VID and PID doesn't return any results anywhere

so it's likely they have been changed . Or you could start trying the tools one by one until you find the right one :)

Just open apart the usb drive and...

MXT6208E (not sure about the E)

What tool can i use?

0

Share this post


Link to post
Share on other sites

I need help with this too

PnP Device ID: VID = 0DD8 PID = 140C

Serial Number: BAE8A68C8448376D

Revision: 1.00/1.00

Device Type: Standard USB device - USB2.0 High-Speed

Chip Vendor: (No match record)

Chip Part-Number: (No match record)

Product Vendor: USB

Product Model: Flash Drive

got a cd drive partition and a regular partition, by the looks of it, its a 512mb drive

0

Share this post


Link to post
Share on other sites

thanks for the reply, just tried that file from the second link and when I opened it I got a notice saying "can't find IO configuration file".

Clicked ok, so when the program loads boxes 1 and 2 say "check the MCU succeeded, but no flash"

anyone know what this means?

EDIT: don't know if this helps but in top right corner it says:

Vendor info: USBVID:0dd8 Scan type: Level 1

Product model: FlasPID:1430 Master type:2033CMS

0

Share this post


Link to post
Share on other sites

hey IOSys any chance you could help me with this one ?

chipgenius:

Device Name: ++[R:][Q:]+USB Mass Storage Device(Flash Drive USB Device)(Flash Drive USB Device)

PnP Device ID: VID = 2002 PID = 1115

Serial Number: CCCBB9998000741

Revision: 5.00/5.00

Device Type: Standard USB device - USB2.0 High-Speed

Chip Vendor: (No match record)

Chip Part-Number: (No match record)

Product Vendor: Flash

Product Model: Drive

Tools on Web: (N/A)

0

Share this post


Link to post
Share on other sites
thanks for the reply, just tried that file from the second link and when I opened it I got a notice saying "can't find IO configuration file".

Clicked ok, so when the program loads boxes 1 and 2 say "check the MCU succeeded, but no flash"

anyone know what this means?

EDIT: don't know if this helps but in top right corner it says:

Vendor info: USBVID:0dd8 Scan type: Level 1

Product model: FlasPID:1430 Master type:2033CMS

I don't have a drive with that controller :( but ..

Generally these programs work by reading a .ini-file when performing the actual flash

so you need to set all the different options, save the .ini-file, then run the program .

Sometimes there's a "production-mode"-option, or something named like that, hidden somewhere that also needs to be enabled . Pay special attention to the "partition"-options, I believe for this tool you need to check the box that matches the total capacity of your drive . Unfortunately the documentation for this tool is non-existent it appears .

Some tools do have good manuals in .pdf, get a couple and read them, these Mass Production Tools all do pretty much the same, just in different ways, so reading the documentation for other MPT's gives you an idea of the principle of operation .

@ DLSS :

Nope, you will need to disassemble the drive and read the markings on the chip .. Is it a e-bay drive ?

0

Share this post


Link to post
Share on other sites
@ DLSS :

Nope, you will need to disassemble the drive and read the markings on the chip .. Is it a e-bay drive ?

nope no e-bay drive its a promotional drive from planet people.

trying to dissasemble it but kinda hard getting it apart ...

*update* ok tore the casing apart , the chip's a chipbank CBM 2091 896607-14

hope that helps :(

0

Share this post


Link to post
Share on other sites

ChipsBank tools are here :

http://translate.google.com/translate?hl=e...3Fname%3Diflash

It's probably one of these you need :

http://translate.googleusercontent.com/tra...37MZU5XyYYIKLYQ

http://translate.googleusercontent.com/tra...HXmYjTljAjYaMrA

The data-sheet is here :

http://www.chipsbank.com/downloads/chips/c...1_datasheet.pdf

Sorry, I don't have a manual for this tool ..

( It's a good chip BTW.. fast, allows multi-LUN, private/public area, CD-ROM LUN, changing of the removable media bit etc etc . Great chip for experimenting :) )

0

Share this post


Link to post
Share on other sites

Hi everybody, I have a USB flash drive and I'm not able to access it anymore.

it is identified as a USBest USB2FlashStorage Vid:Pid 1307:0163 but inside I found a UT165 chip, one 12Mhz quartz and 2 SAMSUNG RAM chip K9LAG08U0B

It is loaded as removable disk but inaccessible, windows says "Insert disk" when opening it.

I have tried to resoldering of clock because it appeared loose..

ChipGenius sent me to UT163 MP Tool, I have tried many versions up to UT165 MP Tool 1.65.25 but they all give errors (0x12 0x54) and when I press start it adds error 0xA2

I really need to recover data on it, any chance?

thanks

0

Share this post


Link to post
Share on other sites

I am in same boat... Suddenly my 32GB A-Data USB got this USBest issue... I downloaded UT163 MPT tool(UT163 MPTool v3.9.35.0) and after installing the driver by MTP (FABULK), it read the USB as following

Port1:

Status:Code 0x54

Capacity 0MB

USB VIP/PID = 0 <------------------------------ChipGenius reads it as 1307/0163

Write Protect = NO

Operation Mode = Unknown

********************************CHIP GENIUS*************

Device Name: +FABULK

PnP Device ID: VID = 1307 PID = 0163

Serial Number: 5&&38C8E674&&0&&1

Revision: (Information not returned)

Device Type: Standard USB device - USB2.0 High-Speed

Chip Vendor: USBest(??)

Chip Part-Number: UT163

Product Vendor: FABULK

Product Model:

********************************************************

I realized from the Flashboot.ru that I can assign VID/PIV using C: \ Program Files \ MDPT \ Driver \ InfUpdate.ex but it does not change anything in the MPT tool after referesh. Parition is set to AUTO in the settings Tab.

If I press start, i get Status Code : 0x54 0xa2

Please kindly help. I had given up on this USB but now there is some hope... Is that FABULK is not loaded correctly or am I using incorrect versoin of MPT tool... 0x54 means Firmware version mismatch with controller type. I see FABULK added into the list of drivers and also the light on my USB flashes with this driver installed....

Please help...

Thanks in advance...

Aray

0

Share this post


Link to post
Share on other sites

@ MtwStark : Sounds like you have a broken drive .

The data is likely still there and can be extracted from the NAND-chip(s) with special hardware,

have a look here for some more info :

http://www.aplusperfect.com/data-recovery

http://www.aplusperfect.com/usb-flash-drive-data-recovery

@ Arayanz :

Try downloading ALL the MPT's for the UT163, sometimes the latest version doesn't work on older

chip-revisions .. I think that's the issue you have, the error-code seems to confirm a version-mismatch .

EDIT : There's a manual for the UT165 MPT here :

http://translate.googleusercontent.com/tra...Tg-MFXn67xxiBqw

Much of it also applies to the UT163 MPT .

0

Share this post


Link to post
Share on other sites
@ Arayanz :

Try downloading ALL the MPT's for the UT163, sometimes the latest version doesn't work on older

chip-revisions .. I think that's the issue you have, the error-code seems to confirm a version-mismatch .

EDIT : There's a manual for the UT165 MPT here :

http://translate.googleusercontent.com/tra...Tg-MFXn67xxiBqw

Much of it also applies to the UT163 MPT .

IOsys Hi,

Thank so much for helping....

I tried following versions (all available) from flashboot.ru and found that problem is still there. Same symptoms even though each time FABULK showed up when flash is connected.

I have tried

UT163 / 3.9.8/3.9.12/3.9.29/3.9.31/3.9.35

Just listing above to make sure i am not missing anything.

Btw, Following is the procedure i am folloiwng

1. Installing the MDPT tool

2. Connecting the flash (A-Data) and driver is installed and it is recognized as FABULK device

3. Starting MDPT tool and click on F1 Settings / Ut163 to change the partition (LUN0) to Auto and partition option checked. I did not change anything on the vendor data side and click OK

4. F3 (enumerate) and getting error "Number of Input devices is not matched with maximum device list!!!"

I am ignoring this considering that my laptop has only three USB slots and min in the tool is 4

5. Port 1 shows the code:0x54 with 0Mb space and VID/PID as 0/0

6. Tried InfUpdate to make the VID/PID as showing in the settings options for MDPT but not change. Even though it unloads and loads the driver (FABULK) with this step.

7. If I press start, the code changes from 0x54 to 0x54/0xa2

Any thoughts?

Thanks for your help

0

Share this post


Link to post
Share on other sites

In the iFlash database the tool listed for 32-GB A-Data drives is MP TOOL UT165 (UT163) 1.65.10.0

http://translate.google.com/translate?hl=e...3Fname%3Diflash

maker              VID           PID        MPT  
A-DATA       32 Gb      1307       0163      MP TOOL UT165 (UT163) 1.65.10.0

A newer version, 1.65.14, is here :

http://translate.google.com/translate?hl=e...3Fname%3Diflash

My guess is that drives above a certain capacity need the UT163/165 combo-tool .

(Maybe A-data has something that could be of use ? http://www.adata.com.tw/en/support.php)

0

Share this post


Link to post
Share on other sites

UPDATE :

From the comments to this tool :

Super Stick Recovery Tool V1.0.2.19 (UT161, UT163, UT165)

fleha a-data 32GB ut165, UT163_setup-v3.9.29.0 betrayed error code 0x54 0xa2, but this has saved! Огромное спасибище!!! Huge spasibische!

it seems that a UT163 identified by VID/PID is sometimes in fact the UT165 !!

http://translate.googleusercontent.com/tra...Of248SipKk1q7rg

0

Share this post


Link to post
Share on other sites

Hi. This is kind of a curve ball, but I've been searching for a solution for about a week now and I just came across this thread. Luckily it's still going!

Anyways, it's an external 1TB HDD, not exactly the right topic for me, but I got a virtual CD problem, too.

Toshiba PH3100U-1EXB.

ChipGenius didn't turn anything up except:

VID:0939

PID:0b13

rest is unknown.

I've tried hunting down official software, closet thing I found was Shd2cdhd.exe which won't work with my model. I've tried inputting the VID and PID into the config file but still, no go. Any other leads for me?

Thanks

0

Share this post


Link to post
Share on other sites

Google is useless if you use the words "toshiba" and/or "PH3100U-1EXB",

all you get is 10.000 mongers wanting to push one of these things :(

( please provide a link to the software you tried (Shd2cdhd.exe) )

Taking the thing apart could probably reveal something interesting but it will void your warranty, so ....

What is on that CD-ROM besides the backup-software ? Can the software be updated ?

If you are lucky the tool is somewhere on the CD-ROM (like it was with U3)..

If none of that works you will need to extract as much info as possible from the device and use that to search

for non-commercial links .. most likely the tool is on some Chinese geek-board .

0

Share this post


Link to post
Share on other sites
UPDATE :

From the comments to this tool :

Super Stick Recovery Tool V1.0.2.19 (UT161, UT163, UT165)

it seems that a UT163 identified by VID/PID is sometimes in fact the UT165 !!

http://translate.googleusercontent.com/tra...Of248SipKk1q7rg

IOSYS,

Thank so much....UT165 MP Tool 1.65.14.0 fixed my solution. Only issue that came up afterwards was that my laptop was not recognizing any USB drive... I did system restore and my 32GB A-Data Flash drive is back into business...

Thanks again...

0

Share this post


Link to post
Share on other sites
Google is useless if you use the words "toshiba" and/or "PH3100U-1EXB",

all you get is 10.000 mongers wanting to push one of these things :(

( please provide a link to the software you tried (Shd2cdhd.exe) )

Taking the thing apart could probably reveal something interesting but it will void your warranty, so ....

What is on that CD-ROM besides the backup-software ? Can the software be updated ?

If you are lucky the tool is somewhere on the CD-ROM (like it was with U3)..

If none of that works you will need to extract as much info as possible from the device and use that to search

for non-commercial links .. most likely the tool is on some Chinese geek-board .

Yeah, tell me about it. Been searching for days now trying to find something.

I somehow broke the virtual cd so the files are all gone from it, but the drive still boots up which is my main problem.

I've done a lot of research, so this is what I've got:

(I did backup the backup software elsewhere)

Backup Software by Dura Micro Inc, including a drive monitor by the same. No other applications, or helpful readmes. Wrote them an e-mail asking if they knew anything about the virtual drive.

The CD+HDD to HDD and vice versa programs are located at http://www.techsupportlive.com/index.php?_...d=8&nav=0,8 and I believe theres a couple more scattered on that site. At least one other program missing from that list.

That led me to the company OnSpec, the people who made that software. Dropped a line at that techsupportlive place in regards to this, which is their tech support page.

I did run a program called HDDScan, it was on the Hiren's BootCD, and it came up with something interesting. Says it's a Hitachi HDT721010SLA360, which in other words, is a Deskstar 7K1000.B. However the firmware listed is ST60A3AA, which doesn't match the model # on some firmware I found at http://www.proware.com.tw . That didn't really turn anything up. I'm guessing it's a bug with HDDScan, since it's a S.M.A.R.T. tool and I'm fairly positive USB drives don't have it, but it's possible that might be what's inside here.

I made the realization just paying attention to when my computer boots, the virtual CD loads first and it loads very quick, while the actual hard drive takes a while to start spinnin'. Makes me think this could be a physical connection that could just be severed.

Any other tools I can try getting info with? Used chipgenius already.

Thanks for gettin back to me

0

Share this post


Link to post
Share on other sites
IOSYS,

Thank so much....UT165 MP Tool 1.65.14.0 fixed my solution. Only issue that came up afterwards was that my laptop was not recognizing any USB drive... I did system restore and my 32GB A-Data Flash drive is back into business...

Thanks again...

I have the same problem. I tried everything that is mentioned above and nothing happens

Chip Genius v3.0 it read USB as following:

Device Name: USB Mass Storage Device(USBest USB2FlashStorage USB Device)

PnP Device ID: VID = 1307 PID = 0163

Serial Number: 5&&2B17EFFA&&0&&3

Revision: 0.00

Device Type: Standard USB device - USB2.0 High-Speed

Chip Vendor: USBest(??)

Chip Part-Number: UT163

Product Vendor: USBest

Product Model: USB2FlashStorage

I tried:

MPTool UT163 v3.9.12 ~ MPTool UT163 v3.9.80

UT165 v1.65.10 ~ UT165 1.65.25.0

Super Stick Recovery Tool V1.0.2.19

and still doesn't work. Please i need some help here

0

Share this post


Link to post
Share on other sites

First, try UFDUtility v 3.2.1.0 , it's the original consumer-application for USBest-controllers

and allows you to do most of the things the MPT does ( It can't flip the RMB )

Go to "Autorun manager" and check "Single Partition" :

http://www.mediafire.com/file/yzvzqmg2z3z/UFDUtility.7z

If that doesn't do it :

Please define "nothing happens" :)

Do any of the MPT's you tried even see the device or anything,

indicated by the first port turning blue in the UI?

(press F3 to enumerate USB-ports, this tool doesn't autoscan)

Some general advice for working with MPT :

Disconnect other USB-devices, especially composite, some MPT install a modified USB-driver,

it might get confused by other devices .

Only insert the UFD after the MPT has started and the driver loaded,

do not access the device with any other programs !

Obviously, you need admin-rights and loading of unsigned drivers must be allowed,

AntiVirus and other security-software should not be allowed to interfere and

XP Pro is still better than Vista/win7 for this task .

0

Share this post


Link to post
Share on other sites
Check this, xSIL251 manufacturer-tool, apparently it's the USB-controller-chip that creates the CD-ROM :

http://www.mediafire.com/?bgwuwq5xzbm

I tried that a while back, seems like that it's designed for another drive. In fact I'm not sure if any of the onspec utilities will work with my drive, I tried contacting them and they told me to ask elsewhere.

So when I run that app it doesn't do anything, just causes my cpu to start heating up, but no window ever pops up.

I did contact duranmicro, they designed the backup software that was on the virtual cd and they sent me a utility for flashing the firmware and removing the cd part. However it was designed for an older model, and I've basically given up my search. I'll probably end up trying to exchange it at best buy.

0

Share this post


Link to post
Share on other sites

To bad it doesn't work, these CD+HDD controllers are a bitch to crack ..

Any chance of downloading the tool they sent you somewhere, these things are almost impossible to find ?

0

Share this post


Link to post
Share on other sites
First, try UFDUtility v 3.2.1.0 , it's the original consumer-application for USBest-controllers

and allows you to do most of the things the MPT does ( It can't flip the RMB )

Go to "Autorun manager" and check "Single Partition" :

http://www.mediafire.com/file/yzvzqmg2z3z/UFDUtility.7z

If that doesn't do it :

Please define "nothing happens" :)

Do any of the MPT's you tried even see the device or anything,

indicated by the first port turning blue in the UI?

(press F3 to enumerate USB-ports, this tool doesn't autoscan)

Some general advice for working with MPT :

Disconnect other USB-devices, especially composite, some MPT install a modified USB-driver,

it might get confused by other devices .

Only insert the UFD after the MPT has started and the driver loaded,

do not access the device with any other programs !

Obviously, you need admin-rights and loading of unsigned drivers must be allowed,

AntiVirus and other security-software should not be allowed to interfere and

XP Pro is still better than Vista/win7 for this task .

I tried this version of UT165 UFDUtility v3.2.4.0 and i didn't try the version of the soft that U send with the link http://www.mediafire.com/file/yzvzqmg2z3z/UFDUtility.7z

because it was impossible to be extracted from WinRar or 7zip. Anyway i tried "Autorun Manager" and the device cannot be found by the utility.

When i tried MPTool (UT163 Multi-Devices Production Tool) v3.9.80.0 and other version of this soft, I followed these steps:

1. I installed the MDPT tool

2. I connected the flash (USBest) and the device was recognized as FABULK device.

3. I pressed F3 to Enumerate the ports

and when i pressed start, shows the code 0xa2 with 0MB capacity

With UT165 MP Tool 1.65.25.0 the same thing but when i pressed start the code changes from 0x12 0x28 to 0x12 0x28 0xa2 always with 0MB

With Super Stick Recovery Tool V1.0.2.19 it shows the size of flash drive 0MB

I think that is a broken drive but i need help for another device if U can with the following information by Chip Genius v2.64

Device Name: USB Mass Storage Device(USB DISK 30X USB Device)

PnP Device ID: VID = 13FE PID = 1D00

Serial Number: 5&&2B17EFFA&&0&&3

Revision: 1.00

Device Type: Standard USB device - USB2.0 High-Speed

Chip Vendor: phison(??)

Chip Part-Number: UP8/UP10 --------> chip Genius V3.0: UP13

Product Vendor: USB

Product Model: DISK 30X

I tried many utilities:

Phison UP13 UP14 UP12 V1.96, MP2232 V1.06, MPALL v2.01.00 (recognize the device but shows a mesagge "Flash Status Error") and all of these utilities show the capacity 0MB. I think that may be exist a solution to fix the problem because when i try with Acronis Media for Workstation can recognize the device and even can be formatted but when I plug in it again and try to access shows me a message "Please insert disk into drive". Please if you have any solution

please inform me. Thanks for your help and Happy New Year 2010. Best regards

0

Share this post


Link to post
Share on other sites