Sign in to follow this  
Followers 0
Sl4y

Kali Linux Setoolkit issue

12 posts in this topic

Hello,

 

when im creating a fake facebook page with my local ip, everything is alright. But i also want people from outside to be able to access my cloned website so i used my public ip but the problem is, that it isnt opening up my fake facebook page but my routers page. Why is this? How can i access my cloned website with my public ip?

 

Thx

0

Share this post


Link to post
Share on other sites

Posted (edited)

42 minutes ago, Sl4y said:

Why is this? How can i access my cloned website with my public ip?

Whats your IP? lets take a look :)

It sounds like you may have set the router to allow remote management access of your router. What you probably need to use is port forwarding instead.

 

Edited by Just_a_User
0

Share this post


Link to post
Share on other sites

Yep, so set your router's management to another port (8080 is the other generic one) and set the fake FB page to be port 80 (or whatever port).

DON'T give us your public IP. 

0

Share this post


Link to post
Share on other sites

Or better yet, turn off remote management unless you absolutely have to have it.  You will also need to forward your computers port that the page is being served on in the router config.

0

Share this post


Link to post
Share on other sites

Posted (edited)

If your router is seen from the outside world and it's the login to administrate the router, login and DISABLE this feature asap! As for reaching your cloned site, you're behind NAT. Port forwarding to your internal web server(needs to be a web server hosting this like apache or nginx, not just a raw file on your desktop) needs to be configured on the home router. This won't effect your router from still working to administrate it on the same port, since you'd be hitting port 80 or 443 on the routers internal IP only. Form an external hit, they'd be forwarded to your internal machines IP, but using 8080 also works, the problem is you'll have to forward for port 80 to 8080 if this is the port your web server listens on.

At a minimum, disable remote viewing of the router's administration panel from the web side or you could get owned pretty quickly if they guess your login details for the router itself and route all your traffic through their own network, or take over the router in other ways depending on it's capabilities, MITM your traffic, etc.

Also, we don't condone attacking people without their permission. While we can't stop you from trying this, realize you could find yourself in trouble with the law if exploiting innocent people without their consent. For learning purposes, sure, test yourself all day long to learn, but you shouldn't attack people at large without their consent.

Edited by digip
0

Share this post


Link to post
Share on other sites

Hello,

 

thanks for the help. For some reason there is nothing where i can set my routers management to another port.

0

Share this post


Link to post
Share on other sites

And i have already port forwarded the port 80 and 443.

0

Share this post


Link to post
Share on other sites
10 minutes ago, Sl4y said:

Hello,

 

thanks for the help. For some reason there is nothing where i can set my routers management to another port.

Just to clarify be careful not to confuse your routers "management" with "remote management" - if your not using remote management then disable it, it may be interfering with your port forwarding rules and will most likely be vulnerable to abuse.

0

Share this post


Link to post
Share on other sites

Hello,

 

i forgot to say that im the only one who is able to see my routers login page. If other ppl try to connect to my cloned website via my public ip nothing will happen.

0

Share this post


Link to post
Share on other sites

Posted (edited)

16 minutes ago, Sl4y said:

Hello,

 

i forgot to say that im the only one who is able to see my routers login page. If other ppl try to connect to my cloned website via my public ip nothing will happen.

Thats a crucial bit of info :)

so when you said

Quote

isnt opening up my fake facebook page but my routers page

you were browsing from inside your network? then sounds like you were trying to browse to your routers IP and not your servers IP, which is kali right? if your on the kali machine you can test by browsing to http://127.0.0.1/ maybe? otherwise fire up your mobile on data (not wifi) and browse to your external IP to check your port forwarding is working correctly.

Edited by Just_a_User
0

Share this post


Link to post
Share on other sites

Hello,

the mistake i made was that i port forwarded for another Computer. Now I enabled it on this Computer my routers login page doesnt show up anymore. But now when i try to access my cloned website via public ip, it just wont load.

0

Share this post


Link to post
Share on other sites
1 hour ago, Sl4y said:

Hello,

the mistake i made was that i port forwarded for another Computer. Now I enabled it on this Computer my routers login page doesnt show up anymore. But now when i try to access my cloned website via public ip, it just wont load.

can you access it locally? i.e. from http://127.0.0.1/ or https://127.0.0.1 - if you cant then maybe your server isnt running? if you can confirm the server is running but it still doesn't show your cloned site try a basic test page first. it could be the clone has problems.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.