Sign in to follow this  
Followers 0
shanec

DNS Issues with DNS suffix from DHCP

1 post in this topic

Hey everyone,

I was having an issue where when I install the Lan Turtle on a computer on our corporate LAN I lose DNS to our internal DNS servers that resolve for our local internal domain anme.

I followed the article below and got it to at least be able to query against those servers but the next issue I am having is the FQDN.  If I specify the FQDN it works fine.

I noticed that it was assigning "lan" as the DNS suffix so I then went into /etc/config/dhcp and changed "option domain" to our interal domain.  I then confirmed on the target machine that it now gets the correct DNS suffix and it works.

But this is the kicker.  What if I am on an engagement where I do not know the local domain ahead of time.  Sure I could plug my laptop in somewhere, get the suffix, connect to the lan turtle, reprogram the domain, and then it would work.

Is there anyway for dnsmasq to update that domain value via DHCP from the ethernet interface?? Then it would reassign that DNS suffix to DHCP on the USB adapter to the target machine.  This should fix my DNS issues.

Any Ideas?

Thanks,

 

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.