Torrey

Mac OS X - How to Share Your Internet Connection

48 posts in this topic

Posted (edited)

Getting the Bash Bunny to Work with Mac

Bash Bunny Payload:

Configure a payload.txt for ATTACKMODE ECM_ETHERNET

Internet Sharing Config:

Internet sharing is easy with the Sharing tab in system preferences. I selected sharing WiFi (or select how you're connected to the internet) with the RNDIS/Ethernet Gadget and then executed the following commands.

Commands:

defaults write /Library/Preferences/SystemConfiguration/com.apple.nat NAT -dict-add SharingNetworkNumberStart 172.16.64.10

defaults write /Library/Preferences/SystemConfiguration/com.apple.nat NAT -dict-add SharingNetworkNumberEnd 172.16.64.200

defaults write /Library/Preferences/SystemConfiguration/com.apple.nat NAT -dict-add SharingNetworkMask 255.255.255.0

defaults read /Library/Preferences/SystemConfiguration/com.apple.nat (optional - use if you want to see if the above commands appended to the configuration)

Network Device Configuration:

58c0957c9c542_ScreenShot2017-03-08at6_32_32PM.png.79f2df9b19cb5fa2083800079203b756.png

 

Notes for the Hak5 Team:

It kind of stinks this wasn't more compatible with the Tetra/Nano configuration. You'd have to alter the SharingNetworkNumberStart and SharingNetworkNumberEnd values for the ICS to work again for the Pineapple.

Edit 1:

Today Mac decided to be a pain, so I had to reboot the computer for ICS to work again. I'm not sure why this happens or if there's an easy way to solve the problem, but this has happened in the past with the Tetra too. Also, I wrote a payload that checks the internet connection for me.

#!/bin/bash
#
# Title:         ICS for Mac
# Author:        Torrey
# Version:       1.0
#
# Sets the attack mode to ECM_ETHERNET for Mac ICS, then tests the internet connection
#
# Red............Starting
# White..........Connected to the internet
# Purple.........Didn't connect to the internet
#

# Starting payload
LED R

# Set the attack mode
ATTACKMODE ECM_ETHERNET

# Are we connected to the internet?
wget -q --spider http://google.com
if [ $? -eq 0 ]; then
    LED R G B
else
    LED R B
fi

Edit 2:

I threw together a quick video running through the steps above for connecting the BB to the Mac ICS. It's a bit generic cause I didn't have much time, but maybe it'll help understand what's necessary for this to work.

Video: https://www.dropbox.com/s/7e5vg0kteijwpsx/ Mac OS X - How to Share Your Internet Connection.mp4?dl=0

Edited by Torrey
1

Share this post


Link to post
Share on other sites

Thanks for sharing this! This was exactly what I was working on today and needed to get working for some ideas I have. Your guide suggests I'm close, but still don't have a working internet connection on the Bunny. 

It looks like everything has been added correctly to /Library/Preferences/SystemConfiguration/com.apple.nat.plist. Here is what I have:

<key>SharingNetworkMask</key>
<string>255.255.255.0</string>
<key>SharingNetworkNumberEnd</key>
<string>172.16.64.200</string>
<key>SharingNetworkNumberStart</key>
<string>172.16.64.0</string>

My network settings match your screenshot and I have Internet Sharing setup between my WiFi card and the RNDIS/Ethernet Gadget. I've restarted Sharing and triple checked settings, but no dice.

What I'm trying to do is use ATTACKMODE ECM_ETHERNET SERIAL to share the internet connection with the Bunny and then use the serial connection to connect and install tools and updates. I get that far, but the internet connection on the Bunny fails.

For the Pineapple you would have to run a command like "ifconfig bridge100 172.16.42.42 netmask 255.255.255.0 up", which would have to be changed for the Bunny's 172.16.64.* scheme. My bridge100 is currently 172.16.64.1.

Did you happen to do anything else to get this working? Could you share the Bunny's network settings for you working config?

0

Share this post


Link to post
Share on other sites

Just for the sake of being thorough could you match up the SharingNetworkNumberStart to mine as well as just using ATTACKMODE ECM_ETHERNET by itself.

defaults write /Library/Preferences/SystemConfiguration/com.apple.nat NAT -dict-add SharingNetworkNumberStart 172.16.64.10

The DHCP range for the Bash Bunny is 10-12, so in reality I could lower the end number as well, but at least matching up with the same start number should help you a lot. Let me know if it works.

0

Share this post


Link to post
Share on other sites

@Torrey Thanks for the reply. I saw another post of yours linking to the latest Hak5 episode and mentioning SSH. I had assumed SSH would be available, but it was not and I didn't see it mentioned in the documentation. After removing SERIAL from the ATTACKMODE line, SSH is now listening and I was able to connect. That's good to know and really simplified things. That was the only reason I thought I'd need SERIAL, for connecting to the Bunny.

Anyway, still no dice on the connection. I tried changing SharingNetworkNumberStart to 172.16.64.10. I thought it was strange because I was sure I had set it to *.10 to begin with. The change doesn't stick for me. Once I stop and restart Sharing, it goes back to *.0. 

0

Share this post


Link to post
Share on other sites

I have noticed that Mac can be temperamental when it comes to ICS, so if you ever connect the device and the network settings screen shot above doesn't fill out the subnet mask, router and DNS server then the sharing won't work. In that case, I switch to regular DHCP, apply it, then switch to DHCP with manual address.

Once you're on SSH, if the "route" command returns quickly, you'll know you're online. It should look like this when connected.

58c0dedaae274_ScreenShot2017-03-08at11_43_17PM.png.987ef6a3d29a17634a03cfb5cfdcccff.png

Keep plugging away though, you're super close from the sound of it. Maybe even reboot the Mac for good measure (I actually had to do this for the Tetra in the past).

0

Share this post


Link to post
Share on other sites

Posted (edited)

@Torrey I've had my Mac setup for the pineapple which is why I haven't messed with it yet. This is what I'm going to have to do with the bunny.  My other objective, because I do internet sharing with pizero, is making a script to switch between the 3 I'm using. I also had a problem with the bash bunny even being recognized my Mac when I first got it.  I couldn't find a fix so I just wiped my SSD and reinstalled OSX all together. Works great now. I think it had something to do with HoRNDIS driver I installed a couple months back. 

im going to make a bash script for this kind of like wp6.sh or bb.sh for the mac

 

EDIT: Im now wondering if changing the IP on the bunny itself to the pineapple ip, I wouldn't have this problem. just a thought

Edited by b0N3z
0

Share this post


Link to post
Share on other sites
On 3/8/2017 at 11:52 PM, Torrey said:

I have noticed that Mac can be temperamental when it comes to ICS, so if you ever connect the device and the network settings screen shot above doesn't fill out the subnet mask, router and DNS server then the sharing won't work. In that case, I switch to regular DHCP, apply it, then switch to DHCP with manual address.

Once you're on SSH, if the "route" command returns quickly, you'll know you're online. It should look like this when connected.

58c0dedaae274_ScreenShot2017-03-08at11_43_17PM.png.987ef6a3d29a17634a03cfb5cfdcccff.png

Keep plugging away though, you're super close from the sound of it. Maybe even reboot the Mac for good measure (I actually had to do this for the Tetra in the past).

@Torrey Your suggestion got it working for me. I had the same thought about rebooting, but couldn't reboot at the time. A combination of a reboot and then switching to DHCP and back to DHCP with Manual Address got everything working. Thanks for sharing your work!

 

0

Share this post


Link to post
Share on other sites

Just an Idea I started playing around with last night and did a lot of searching on the bashbunny for, but how about we change the IP of the bunny to the same ip as the pineapple and that way as an OSX user we wouldnt have to worrry about it.  Unless that Ip is hardcoded into all the modules and other shit that would make it not work properly.

0

Share this post


Link to post
Share on other sites
On 3/11/2017 at 8:04 AM, b0N3z said:

Just an Idea I started playing around with last night and did a lot of searching on the bashbunny for, but how about we change the IP of the bunny to the same ip as the pineapple and that way as an OSX user we wouldnt have to worrry about it.  Unless that Ip is hardcoded into all the modules and other shit that would make it not work properly.

You should be able to detect the device by MAC, so no need to change the IP address.

0

Share this post


Link to post
Share on other sites

I tried a version of the "are we connected" script and according to that (when run as a payload) it shows that I do have an internet connection, yet (somehow) when I run it when ssh'ed into the bashbunny... it fails. Also, wget is taking forever to finish in both.

payload.txt: (passes)

LED R
ATTACKMODE ECM_ETHERNET

LED R G B
ifconfig > /root/udisk/loot/ifconfig

while true; do
LED B
wget -q --spider http://google.com

if [ $? -eq 0 ]; then
    LED G
    sleep 5
else
    LED R
    sleep 5
fi
done

 

test.sh: (fails)

#!/bin/bash
wget -q --spider http://google.com
if [ $? -eq 0 ]; then
    echo passed
else
    echo failed
fi

 

ifconfig output for both:

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:8 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:520 (520.0 B)  TX bytes:520 (520.0 B)

usb0      Link encap:Ethernet  HWaddr 5a:00:00:5a:5a:00
          inet addr:172.16.64.1  Bcast:172.16.64.255  Mask:255.255.255.0
          inet6 addr: fe80::5800:ff:fe5a:5a00/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:60 errors:0 dropped:0 overruns:0 frame:0
          TX packets:11 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:26507 (25.8 KiB)  TX bytes:690 (690.0 B)

 

0

Share this post


Link to post
Share on other sites

It appears to have fixed itself in the last 12 hours... nevermind

0

Share this post


Link to post
Share on other sites

Having trouble sharing my OSX internet connection with my new BashBunny.

Tried to follow the recipe here but my network settings look very different for the RNDIS/Ethernet Gadget connection

The settings are things like Telephone Number, Account Name, and Password; in other words, my MacBook Air thinks this is a modem.

Would attach a screen shot but don't see how others are accomplishing that (all that's in the menu is Insert Image from URL and Insert Existing Attachment).

Any help would be most appreciated. 

 

0

Share this post


Link to post
Share on other sites

Got a bit further along, but still no DNS:

           _____  _____  _____  _____     _____  _____  _____  _____  __ __
 (\___/)  | __  ||  _  ||   __||  |  |   | __  ||  |  ||   | ||   | ||  |  |
 (='.'=)  | __ -||     ||__   ||     |   | __ -||  |  || | | || | | ||_   _|
 (")_(")  |_____||__|__||_____||__|__|   |_____||_____||_|___||_|___|  |_|
 Bash Bunny by Hak5     USB Attack/Automation Platform

Last login: Wed Dec 31 16:00:59 1969 from 172.16.64.64
root@bunny:~# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         172.16.64.64    0.0.0.0         UG    0      0        0 usb0
172.16.64.0     *               255.255.255.0   U     0      0        0 usb0
root@bunny:~# ping google.com
ping: unknown host google.com

 

0

Share this post


Link to post
Share on other sites

Posted (edited)

3 hours ago, hipcrime said:

Got a bit further along, but still no DNS:

           _____  _____  _____  _____     _____  _____  _____  _____  __ __
 (\___/)  | __  ||  _  ||   __||  |  |   | __  ||  |  ||   | ||   | ||  |  |
 (='.'=)  | __ -||     ||__   ||     |   | __ -||  |  || | | || | | ||_   _|
 (")_(")  |_____||__|__||_____||__|__|   |_____||_____||_|___||_|___|  |_|
 Bash Bunny by Hak5     USB Attack/Automation Platform

Last login: Wed Dec 31 16:00:59 1969 from 172.16.64.64
root@bunny:~# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         172.16.64.64    0.0.0.0         UG    0      0        0 usb0
172.16.64.0     *               255.255.255.0   U     0      0        0 usb0
root@bunny:~# ping google.com
ping: unknown host google.com

 

Turn off ICS, wait about a minute. Before you turn it back on use the drop down to choose which interface you want to share from (e.g. Wifi) and then enable it. Afterwards, reconnect your BB.

Edited by Torrey
0

Share this post


Link to post
Share on other sites

Turned off ICS and waited for a long time (20 minutes or so).

Came back later and reconfigured ICS then connected BashBunny.

Configured network device and SSH'd into BashBunny; but still same result:

           _____  _____  _____  _____     _____  _____  _____  _____  __ __
 (\___/)  | __  ||  _  ||   __||  |  |   | __  ||  |  ||   | ||   | ||  |  |
 (='.'=)  | __ -||     ||__   ||     |   | __ -||  |  || | | || | | ||_   _|
 (")_(")  |_____||__|__||_____||__|__|   |_____||_____||_|___||_|___|  |_|
 Bash Bunny by Hak5     USB Attack/Automation Platform

Last login: Wed Dec 31 16:06:32 1969 from 172.16.64.64
root@bunny:~# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         172.16.64.64    0.0.0.0         UG    0      0        0 usb0
172.16.64.0     *               255.255.255.0   U     0      0        0 usb0
root@bunny:~# ping google.com
ping: unknown host google.com
root@bunny:~#

 

0

Share this post


Link to post
Share on other sites

I got it to work. 

Short answer: use root@bunny:~# route add default gw 172.16.64.(octet assigned to your BB by the mac)

so for mine it was root@bunny:~# route add default gw 172.16.64.10

 

 

Long answer

I had the same problem described by HipCrime above.   after scratching my head for a minute and rebooting the mac and trying all the suggestions in the post I finally went back to the basics (always do it by the numbers when your stumped).

 

So I connected up the BB opened a term on the mac and check ifconfig to see where the BB IP-addrs was set

 

next I check networking to see if it matched and to see what the other settings were (originally the DNS server was set to 172.16.64.1 , i set it to 8.8.8.8 to match what was in the BB /etc/resolv.conf).  

 

Next I ssh into the BB using ssh root@172.16.64.1

in a separate shell on the mac I started tcpdump on the BB interface (in my case en10)

tcpdump -i en10

back in BB land I ran netstat -r to see the route table and watched the tcpdump action

looking in the tcpdump window I see ARPs for 172.16.64.64

 

and the route table on BB shows:

 

Which can't be right for ICS because ifconfig on the mac shows 172.16.64.10 as the interface and while I get why the OS X networking UI would show 172.16.64.1 as the router, I didn't get where the 172.16.64.64 in the BB route table came from. The BB's default route should point to the interface assigned to it in OS X (in my case the 172.16.64.10 ip).  so a quick 'route add' later and the BB was up and connecting like a champ

 

 

hope this helps :)

1

Share this post


Link to post
Share on other sites

hmmm... not sure where all the screen shots I added to the post got off to...

 

1

Share this post


Link to post
Share on other sites
1 hour ago, graythang said:

I got it to work. 

Short answer: use root@bunny:~# route add default gw 172.16.64.(octet assigned to your BB by the mac)

so for mine it was root@bunny:~# route add default gw 172.16.64.10

 

 

Long answer

I had the same problem described by HipCrime above.   after scratching my head for a minute and rebooting the mac and trying all the suggestions in the post I finally went back to the basics (always do it by the numbers when your stumped).

 

So I connected up the BB opened a term on the mac and check ifconfig to see where the BB IP-addrs was set

 

 

next I check networking to see if it matched and to see what the other settings were (originally the DNS server was set to 172.16.64.1 , i set it to 8.8.8.8 to match what was in the BB /etc/resolv.conf).  

 

 

Next I ssh into the BB using ssh root@172.16.64.1

in a separate shell on the mac I started tcpdump on the BB interface (in my case en10)

tcpdump -i en10

back in BB land I ran netstat -r to see the route table and watched the tcpdump action

looking in the tcpdump window I see ARPs for 172.16.64.64

 

 

and the route table on BB shows:

 

 

Which can't be right for ICS because ifconfig on the mac shows 172.16.64.10 as the interface and while I get why the OS X networking UI would show 172.16.64.1 as the router, I didn't get where the 172.16.64.64 in the BB route table came from. The BB's default route should point to the interface assigned to it in OS X (in my case the 172.16.64.10 ip).  so a quick 'route add' later and the BB was up and connecting like a champ

 

 

 

hope this helps :)

Awesome you found a way to make it work. The reason why you see 172.16.64.64 is that it's defined in /etc/network/interfaces.d/usb0 on the BB.

58cbf940e0a47_ScreenShot2017-03-17at10_56_45AM.png.9d180d7e3aa48d52941aaaba94723777.png

That's why the BB wiki (under ICS sections) and this thread says to set the BB's IP manually to 172.16.64.64.

1

Share this post


Link to post
Share on other sites

Thanks for the post....  That will teach me to read more carefully - I completely missed that!  could'a saved me some time LOL

Live and learn

 

0

Share this post


Link to post
Share on other sites

Still no luck.  IP address for my Mac is 172.16.64.64 and for my BashBunny it is 172.16.64.1.  

As before, can SSH into the BB as root, but the route command takes many minutes then returns this:

root@bunny:~# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         172.16.64.64    0.0.0.0         UG    0      0        0 usb0
172.16.64.0     *               255.255.255.0   U     0      0        0 usb0

Obviously it's timing out trying to return the route information.

On my Mac, the BB is assigned 172.16.64.1, so added this route:

root@bunny:~# route add default gw 172.16.64.1

Once again, it take quite a while for the route command to return this:

root@bunny:~# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         172.16.64.1     0.0.0.0         UG    0      0        0 usb0
default         172.16.64.64    0.0.0.0         UG    0      0        0 usb0
172.16.64.0     *               255.255.255.0   U     0      0        0 usb0

None of this results in a usable internet connection:

root@bunny:~# ping google.com
ping: unknown host google.com

Only have a Mac running Mountain Lion, so cannot compare to what happens on Windows or Linux.

Tried many combinations of reboot, turning off ICS then waiting, using DHCP, setting up Manual network, etc.

 

 

0

Share this post


Link to post
Share on other sites

Mac can ping the BB:

$ ping 172.16.64.1
PING 172.16.64.1 (172.16.64.1): 56 data bytes
64 bytes from 172.16.64.1: icmp_seq=0 ttl=64 time=0.452 ms
64 bytes from 172.16.64.1: icmp_seq=1 ttl=64 time=0.463 ms
^C
--- 172.16.64.1 ping statistics ---
2 packets transmitted, 2 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 0.452/0.458/0.463/0.006 ms

BB can not ping the Mac:

root@bunny:~# ping 172.16.64.64
PING 172.16.64.64 (172.16.64.64) 56(84) bytes of data.
^C
--- 172.16.64.64 ping statistics ---
3 packets transmitted, 0 received, 100% packet loss, time 1999ms

Definitely something wrong with BB's network.

0

Share this post


Link to post
Share on other sites

When connected the bashbunny shows up as 172.16.64.10, for internet sharing it should show up as 172.16.64.64.  This is what I have noticed in linux when using it.  Still haven't tried it with OSX yet.

0

Share this post


Link to post
Share on other sites
17 hours ago, hipcrime said:

Mac can ping the BB:


$ ping 172.16.64.1
PING 172.16.64.1 (172.16.64.1): 56 data bytes
64 bytes from 172.16.64.1: icmp_seq=0 ttl=64 time=0.452 ms
64 bytes from 172.16.64.1: icmp_seq=1 ttl=64 time=0.463 ms
^C
--- 172.16.64.1 ping statistics ---
2 packets transmitted, 2 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 0.452/0.458/0.463/0.006 ms

BB can not ping the Mac:


root@bunny:~# ping 172.16.64.64
PING 172.16.64.64 (172.16.64.64) 56(84) bytes of data.
^C
--- 172.16.64.64 ping statistics ---
3 packets transmitted, 0 received, 100% packet loss, time 1999ms

Definitely something wrong with BB's network.

hipcrime give this a shot. (Im assuming your on a Mac still)  I'm sure you already now where stuff is but Im being very verbose in case anyone else reads this that doesn't already know where to find everything... :)

Probably not absolutely necessary but just to be sure everything is at defaults you can reset the BB -  put the switch to armed mode (position closest to the USB plug) next plug it in and unplug it as soon as the green led blinks off.  Do this 3 times (I do it 4 times just to be sure & because according to my wife I can't count lol).  Then plug it in and let it run. you should see a red blinking led after a bit. let it run until it finishes (can't recall if it show a green or blue led when done but I think it was blue...hmmmm looks like more than my counting skills have taken a vacation :P  ).  

You should also see it popup on your screen as normal. (tip, if not open the Disk Utility and check for it there... if shows grey'ed out, right click and select Mount  [ you can find disk utilities in finder under Applications - Utilities].  

Once the BashBunny shows up, open it and in finder navigate to "Payloads" -> Switch1" and open the "payload.txt" file there. For MAC the text you should see is "ATTACKMODE ECM_ETHERNET"  (w/o the quotes). Close the file (don't forget to save it if you had to make changes). 

Now Eject the BashBunny (you can right click on and select the Eject option - or drag it to the trash can)

Next

1) open terminal window on the mac

2) enter the commands below:  (note if your running as admin you won't need to use 'sudo' - but... you should really think about changing that habit)

  •  sudo defaults write /Library/Preferences/SystemConfiguration/com.apple.nat NAT -dict-add SharingNetworkNumberStart 172.16.64.64
  •  sudo defaults write /Library/Preferences/SystemConfiguration/com.apple.nat NAT -dict-add SharingNetworkNumberEnd 172.16.64.200
  •  sudo defaults write /Library/Preferences/SystemConfiguration/com.apple.nat NAT -dict-add SharingNetworkMask 255.255.255.0

    Then enter:

  •     defaults read /Library/Preferences/SystemConfiguration/com.apple.nat

    make sure you see the following listed somewhere in the text that now shows in the terminal:

            SharingNetworkNumberEnd = "172.16.64.200";

            SharingNetworkNumberMask = "255.255.255.0";

            SharingNetworkNumberStart = "172.16.64.64";

3)  next you want to plug in the BashBunny and open "Network" under System Preferences 

  • click on "RNDIS/...t Gadget" in the left window of the UI  (if its not there go back and check the contents of the payload.txt file)
  • verify "Configure IPv4:" is set to "Using DHCP with manual address"  (Thanks again Torrey for pointing that out)
  • in "IP address:" set it to read "172.16.64.64"

        (note if the lock at the lower left is closed, click it and enter the admired/pw so you can make changes)

4) now open "Sharing" under "System Preferences"

  • Under "Share your connection from:" make sure you've selected the type of connection your using (Wi-Fi or Ether net etc), 
  • Under "To computers using:"  add check marks to "USB 10/100 LAN" & "RNDIS/Ethernet Gadget"
  • Now click "Internet Sharing" in the right window - this causes a popup window - click on "Start" when you see it.

5)  in the terminal window enter "ifconfig"  you should see and entry named bridge - mine reads "bridge100:" and lists "inet 172.16.64.64"

  • Next ssh to the BB "ssh root@172.16.64.1" and log in

        on the BB ssh terminal run:

  • "ipconfig"  you should see "usb0 with inet add: 172.16.64.1

       Then

  • "netstat -r"  you should see 172.16.64.64 under the "Gateway" column.

if all of this is in place you should be able to ping www.google.com and get a response.  

let me know if it works :)

 

    

 

0

Share this post


Link to post
Share on other sites

Hey @Torrey and @graythang,

I really appreciate you guys figuring this out. Unfortunately I have not been able to reproduce your results and I'm not sure where I am going wrong. I did notice that you both have different ips for the "SharingNetworkNumberStart" value (172.16.64.10 vs 172.16.64.64), but neither worked for me. Another missing piece for me that is in both of your instructions, but not present in my setup is the "USB 10/100 LAN" as a device to share the internet with; I only see the "RNDIS/Ethernet Gadget" in the list to check. I see all of the proper ip addresses in your list gray, but when I try to ping google, it fails. Not sure what else to try, but I am accepting suggestions. I'm running an old macbook pro 2.6ghz with an i7 from 2012 (osx 10.12). 

Note: I have been successfully sharing my internet connection through a linux vm as described here: 

 

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.