nycaleksey

Members
  • Content count

    3
  • Joined

  • Last visited

  • Days Won

    2

About nycaleksey

  • Rank
    Newbie

Recent Profile Visitors

320 profile views
  1. I did some further digging, familiarized myself with OpenWRT for the first time, and I think I found a problem that prevents OpenVPN module from working - it does not enable openvpn.custom_config in UCI. So, after manually running uci set openvpn.custom_config.enabled=1 uci commit OpenVPN starts working just fine. This should be done as part of enabling the module by Module Manager, I think.
  2. I have made some progress - everything works fine if I run openvpn manually: root@turtle:/tmp# /usr/sbin/openvpn --daemon --config /etc/openvpn/my-vpn.conf however, /etc/init.d/openvpn start" still does not start openvpn. I have looked through that script and it's quite complex - it tries building configs on the fly and does some other stuff. So, for now, I made a simple bandaid solution - in /etc/turtle/openvpn module definition I have replace start routine from "/etc/init.d/openvpn start" to "/usr/sbin/openvpn --daemon --config /etc/openvpn/my-vpn.conf " and the stop routine with "killall openvpn" This works for me - the LanTurtle autostarts OpenVPN when booting up and keeps the tunnel up. Hopefully this will be fixed in the firmware updates.
  3. Hi, I just got a Lanturtle and first thing I wanted to do is to make it OpenVPN out to my homebase. I just copied my regular OpenVPN config that works on all other devices incuding IOS devices - but it doesn't work. When I start the module it confirms that OpenVPN is started and even gives out PIDs but then it shows it as "Stopped". The logs on my openvpn server show no connection attempts whatsoever. I cannot find the location of any OpenVPN logs or output on the LanTurtle, and trying run the /usr/sbin/openvpn binary results in empty output. My openvpn config file looks like this: client dev tun proto udp remote x.x.x.x xxx resolv-retry infinite nobind persist-key persist-tun cipher AES-128-CBC comp-lzo verb 3 <ca> -----BEGIN CERTIFICATE----- ca -----END CERTIFICATE----- </ca> <cert> -----BEGIN CERTIFICATE----- cert -----END CERTIFICATE----- </cert> <key> -----BEGIN PRIVATE KEY----- key -----END PRIVATE KEY----- </key> could someone help and point me out in the right direction - how do I see why exactly OpenVPN does not start? Thank you